
Programos paleidimas Start-> Programs-> Microsoft Excel. 
 

 
 
 

• Lentelės kursorius – paryškintų linijų rėmelis darbo lentelėje, kuris žymi aktyvų, parengtą 

duomenų rašymui,  ekrane rodomos lentelės langelį.  

• Valdymo komandų meniu - pele arba funkciniais valdymo klavišais parenkamų paketo valdymo 

komandų vardų sąrašas arba komandas vaizduojančių ženkliukų rinkinys. 

• Įvedimo laukas – ekrano eilutė tarp valdymo komandų ženkliukų juostos ir darbo lango, kurioje yra 

rodomi  aktyvaus langelio saugomi arba į jį įvedami duomenys.        

• Valdymo ženkliukų meniu - pele parenkamų valdymo komandų grafinių įvaizdžių juosta. 

• Darbo lentelių parinkimo žymės – į darbo langą siunčiamų darbo knygos lentelių parinkimui 

skirtos žymės. 

• Informacinis laukas – ekrano dalis su duomenimis apie paketo darbo režimą ir tvarkomo 

dokumento savybes. 

• Procesų konstruktorius (Wizard) – dialoginė paketo valdymo priemonė, kuri siūlo vartotojui 

tipinių lentelių tvarkymo darbų organizavimui skirtą komandų seką ir konsultuoja apie tų veiksmų valdymo 

būdus. 

 
Pačiame viršuje, kaip ir daugelyje Windows terpės programų, yra meniu eilutė, truputi žemiau 

standartinė įrankių juosta, na o dar žemiau turėtų būti formulės juosta Formula Bar. Toliau prieiname prie 
pačios Excel lentelės. Ji yra sudaryta iš ląstelių cells, kurios yra gražiai surikiuotos į stulpelius columns ir 
eilutes rows. Kairėje ekrano pusėje yra vertikaliai sunumeruotos eilutės (nuo 1 iki 65536), o viršuje - 
horizontaliai stulpeliai (nuo A iki IV). Kiekviena ląstelė turi savo koordinates, eilutės ir stulpelio atžvilgiu. 
Pvz.: 



A1 B1 C1 

A2 B2 C2 

 
Nurodant ląstelių koordinates ir yra susiejamos ląstelės viena su kita. Suaktyvinus ląstelę, jos 

koordinatės yra rodomos kairėje formulės juostos pusėje, vadinamoje vardo dėžutėje name box.  
Puslapiai Sheet 
Pačioje lentelės apačioje yra Excel'io puslapiai, kurie pagal nutylėjimą būna trys arba keturi 

(priklausomai matyt nuo versijos). Yra tokios kortelės su užrašais: Sheet1, Sheet2.... Juos galima pervardinti 
ir įterpti. Puslapiai Sheet labai praverčia tada, kada reikia suvesti daug duomenų iš kurių yra gaunami 
konkretūs rezultai, juos perkeliame į kitą puslapį, kurį paruošiame taip, kad būtų patogu spausdinti.  

Ląstelės fomatai 
MS Excel programos ląstelė turi gana nemažai fizinių formatų.  
 

 
 
Juos visus keisti galima taip: pažymėjus ląstelę ar jų bloką Format-> Cells..(arba Ctrl+1) ir ten 

atsidaro atsidariusiame lange yra šešios kortelės, apie kurias toliau ir kalbėsime:  
1. Pirmoji kortelė su pavadinimu Number. Joje galima ląstelei priskirti kategoriją. Lauke 

Category yra išvardintas kategorijų sąrašas: General, Number, Currency ir tt...  

a. General - tai standartinis ląstelės formatas, jei tai bus tekstas, jis bus rašomas 
nuo kairiojo krašto, jei skaičius tai dešiniame, jei įrašysite datą, ji bus tokiu formatu, kokiu 
parašysite, bet Excel'is, supras, kad tai yra data.  

b. Number - galima nurodyti kiek skaičių po kablelio rodyti, (laukas Decimal 
place). Jei prie punkto Use 1000 Separotor (.) uždėsite varnelę, tada skaičiai kas tūkstantoji 
dalis bus atskiriami (.), pvz.: 1000 atrodys šitaip 1.000. Lauke Negative numbers galima 
pasirinkti kokia spalva rodyti teigiamas ir neigiamas reikšmes.  

c. Currency - galima priskirti kokios nors šalies valiutos simbolį. Jei priskirsime 
litus, tai toje ląstelėje automatiškai bus rodomas skaičius kurį parašysite ir prisidės simbolis 
LT. Taip kaip ir ankstesniame punkte galima pasirinkti skaičių po kablelio kiekį ir teigiamų 
neigiamų reikšmių spalvas.  

d. Accounting - jis taip pat prideda piniginio vieneto simbolį.  

e. Date - tai datos formatas. Ląstelėje, kurioje uždėtas toks formatas, turi būti 
rašoma data. Jei jūs ten parašysite skaičių MS Excel jį pavers į datą. Kokiu tipu rodyti datą, 



galima pasirinkti lange Type. Kaip Excel'is paverčia skaičių į datą? Paimkime ant ląstelės 
uždėkite formatą Date ir pasirinkite tipą, kad rodytų mėnesio pavadinimą, dieną, metus. Tada 
toje ląstelėje įrašikite skaičių 36526. Tokiu atveju gausite: sausis 1, 2000. MS Excel 
skaičiuoja kiek dienų praėjo nuo 1900.01.01 (imtinai). Parašius vienetą gautume: sausis 1, 
1900  

f. Time - tai laiko formatas. Ši kategorija labai panaši į Date, jos net siejamos, 
tipuose galima pasirinkti, kad rodytų datą ir laiką. Šis formatas lygiai taip pat verčia skaičių į 
laiką. Tik laikas yra skaičius po kablelio, t.y. kokia dalis paros. Pvz.: viena valanda yra 
0,0416666... paros. Tokiu atveju pasirinkus tipą, kur yra rodomas laikas, bet nerodoma data ir 
parašius 0,0416666, matytume 1:00.  

g. Percentage - Šioje ląstelėje bus rašomi procentai. Prie skaičiaus bus 
pridedamas ženklas "%" ir įrašytas skaičius automatiškai verčiamas į procentus.  

h. Fraction - šis atributas skaičius verčia į trupmenas. Pirmi trys atributai verčia 
tiksliai kokia yra, tik galima pasirinkti trupmenos dydį ta prasme į kiek skaičių po kablelio 
atsižvelgti likę atributai, taip pat, tik skirtingu tikslumu apvalina. Pvz.: parašius 1,5 gausime 1 
1/2.  

i. Scientific - ląstelėlė su tokiu atributu jūsų įrašyta skaičių rodys šitaip: 
1,00E+01. Decimal place pasirinktas skaičius reiškia kiek ženklų po kablelio rodyti. Kam tai 
reikalinga? Tai reikalinga tada, kai tenka rašyti ypatingai ilgus skaičius, kad jie matytus nėra 
būtina, sakykime mums reikalinga tik tokių skaičių suma. Tokiu atveju ląstelėje, kurioje bus 
suma, pasirinksime atributą Number ir matysime visą skaičių. O ląstelėje į kurią vesime 
matysime taip pvz.: įvedame 123456789, ląstelėje bus taip: 1,23E+08, tai reiškia, kad skaičius 
prasideda 123... ir nuo kablelio dar yra aštuoni sveiki skaitmenys.  

j. Text - tai tiesiog ląstelė skirta rašyti tekstui, nors ten rašysite ir skaičius, bet 
excel'is juos supras kaip tekstą.  

k. Special - yra keturi formatai, tai ZIP kodas, ZIP + 4 skaičiai, telefono numeris 
ir specialus numeris. Pirmasis rašo penkis skaičius. Jei parašysite 1, tai gausite 00001. 
Antruoju atveju iš vieneto bus 00000-0001. Telefono numeris nelabai atitinka Lietuvos 
standartą, todėl geriau naudoti Custom, jis rašomas tokiu formatu 123-45-6789, o specialus, 
tai čia būtų užmiesčio arba mobilus, Lietuvai taip pat nelabai tinka, jo formatas toks (12) 345-
67-8999.  

l. Custom - šis atributas leidžia susikurti savo ląstelės šabloną. 

2. Antroji kortelė pavadinimu Alignment. Joje galima nurodyti, kaip tekstas bus 
lygiuojamas horizontalumo atžvilgiu Horizontal:, vertikalumo Vertical:. Taip pat ląstelėje galima 
pasukti tekstą kokiu nors kampu (Orentation). Yra ir trys punktai, prie kurių galima uždėti varneles:  

a. Wrap text - jei tekstas netilps ląstelėje, jis bus keliama į kitą eilutę.  

b. Shrink to fit - jei tekstas netilps ląstelėje, jis bus suspaudžiamas tiek, kad tilptų į 
ląstelę.  

c. Merge celles - tik tik jei pažymėta ląstelių blokas, tokiu atvejų iš bloko yra 
padaroma viena ląstelė.  



3. Trečioji kortelė Font. Na apie ją tikriausiai nieko daug kalbėti nereikia, nors ir nėra 
daug ką pasakyti. Čia galima pasirinkti šriftą, stilių, dydį, galima tekstą pabraukti, nubraukti, parašyti 
indekse ir t.t.  

4. Ketvirtoji kortelė Border. Ji yra skirta ląstelėms uždėti rėmelius, kurie bus 
spausdinami (tos linijos, kurias jūs matėte iki šiol, jos nėra spausdinamos(Gridlines)).  

5. Penktoji kortelė Patterns. Čia galima pasirinkti ląstelės fono spalvą ir uždėti kokį nors 
štrichą, taip pat galima pasirinkti ir štricho spalvą. Lauke Sample, po kiekvieno veiksmo jūs matysite 
pavyzdį, kaip atrodys jūsų ląstelė arba blokas.  

6. Na paskutinioji kortelė Protection. Ten galima ant dviejų punktų uždėti arba nuimti 
varneles. Locked, reiškia, kad ši ląstelė yra rakinama. Pagal nutylėjimą, visos ląstelės yra rakinamos. 
Bet sakykime, kad jūs darote, kokią dinaminę lentelę, į kurią kiti žmonės ves tam tikrus duomenis, ir 
jie bus, sakykime sumuojami. Tokiu atveju tas ląsteles, į kurias bus vedami duomenys padarykite ne 
Locked, o kuriuose bus formulės, palikite Locked. Paskui meniu eilutėje Tools-> Protection-> 
Protect sheet... galima užrakinti puslapį, išskyrus tas lasteles, nuo kurių nuimtas atributas Locked.  

 
Darbas su ląstelėmis ir blokais 
Kaip pastebėjote atsidarius MS Excel programą, ląstelė A1 būna ryškiau apibraukta. Tai reiškia, kad ji 

yra pažymėta. Pažymėti kitą ląstelę labai paprasta, tiesiog užvedate ant jos pelės žymeklį ir paspaudžiate kairį 
pelės mygtuką, arba su klaviatūros rodyklėmis aukštyn, žemyn, į kairę ir į dešinę nueinate iki norimos 
ląstelės. Ta ląstelė arba blokas kuris yra apvestas ryškiau yra pažymėtas (toliau vadinsime aktyvus). Aktyvią 
ląstelę galima kopijuoti perkelti, formatuoti ir t.t. Viskas kas bus daroma, bus priskiriama būtent aktyviai 
ląstelei arba jų blokui. 

Jei jūs užvesite pelės žymeklį ant aktyvios ląstelės, paspausite kairį pelės mygtuką ir vesite pelę 
norima kryptimi, tada žymėsis ląstelių blokas. Dažnai reikia, kad norimą pažymėti bloką sudaro didelis 
stulpelis, ilga eilutė ar net visas Excel lapas. Tokiu atveju su pele vesti yra labai nepatogu ir tai užima daug 
laiko. Tada reikia daryti šitaip:  

a. Norint pažymėti stulpelį reikia tiesio paspausti kairį pelės mygtuką ant virš stulpelio 
esančios raidės (A..IV). Norint pažymėti kelis šalia esančius stulpelius - paspaudus laikyti ir vesti pelę 
norima kryptimi. (Žiūrėti pvz. nr.1)  

b. Norint pažymėti eilutę - viskas taip pat, tik pelę reikia užvesti ant šalia esančių skaičių. 
(Žiūrėti pvz. nr.1)  

c. Norint pažymėti visą lapą reikia paspausti kairį pelės mygtuką užvedus ant laukelio, 
kur susikerta stulpelių ir eilučių numeracija arba paspausti Ctrl+A. (Žiūrėti pvz. nr.1)  
Kartais būna taip, kad reikia pažymėti 2 ar daugiau ląstelių blokus, kurie yra ne šalia vienas kito. 

Tada, pažymime vieną bloką, laikydami paspaudę Ctrl klavišą žymime antrą bloką ir t.t., kiek tik jums reikia. 
Kai tenka, kad būtų dvi ar daugiau vienodų ląstelių (ar blokų) jas galima kopijuoti. Paprasčiausiai taip, 
pažymime norimą kopijuoti ląstelę(bloką), Edit-> Copy. Aplink tą ląstelę (bloką) atsiras bėgantis punktyrinis 
apvadas. Pažymite tą ląstelę, į kurią kopijuosite ir Edit-> Paste. Jei buvo aktyvus blokas, tada pažymėti (į kur 
kopijuoti) reikia tik kairiąja viršutinę ląstelę. Jei ląstelėje buvo ne pastovi, o kintama reikšmė, (buvo įrašyta 
kokia nors formulė), tada ji pasislinko ir gavosi tikriausiai ne tai ko jūs norite.  MS Excel'is turi galimybę ir 
pakelti ląstelę (bloką) iš vienos vietos į kitą. Pažymime ląstelę (bloką), Edit-> Cut. Aplink tą ląstelę (bloką) 
atsiras bėgantis punktyrinis apvadas. Pažymite tą ląstelę į kurią perkelsite ir Edit-> Paste.  

Specialus ląstelių (blokų) kopijavimas.  



Atsitinka kartais taip, kad jūs, sakykime, pasidarėte lentelę, į ją surašėte reikšmes ir tada jums prireikė 
dar vienos tokios lentelės šalia, kur jau reikės rašyti kitas reikšmes. Žinoma jūs galite nukopijuoti tokią pat ir 
perrašyti reikšmes. Bet kam tai daryti, kai MS Excel'is komandą Paste special. Ten yra sąrašas punktų ir 
langas suskirstytas į dalis: Paste, Operation ir yra trys papildomos komandos.  

a. All - viską, taip kaip yra, nepakeičia stulpelio pločio ar eilutės aukščio.  

b. Formulas - kopijuoja tik formulę.  

c. Values - kopijuoja tik reikšmes. Jei buvo kintamieji, tai pasidarys pastovi reikšmė.  

d. Formats - kopijuoja formatą: rėmelius, fontus, spalvą ir t.t., tik taip pat nekopijuoja 
dydžio.  

e. Comments - kopijuoja komentarą. 

f. Validation - kopijuoja tik ląstelės duomenų patvirtinimą. 

g. All axcept borders - kopijuoja viską išskyrus rėmelius.  

h. Column widths - kopijuoja tik stulpelio plotį.  

i. None - tai reiškia, kad nereikia jokios operacijos.  

j. Subtract - kopijuojamą reikšmę atima iš ląstelėje esančios reikšmės.  

k. Multiply - padaugina iš ląstelėje esančios reikšmės.  

l. Divide - ląstelėje esančią reikšmę padalina iš kopijuojamos reikšmės.  

m. Transpose - kopijoje lentele gaunasi pasukta 90 laipsnių kampu.  

n. Paste link - padoro nuoruodą į kopijajamas ląsteles. Pvz.: jei kopijuojate ląstelę A1 į 
B5, tai B5 ląstelė bus "=A1" (rodys A1 ląstelės reikšmę), jei pakeisite A1 pasikeis ir B5.  
Eilučių, stulpelių, ląstelų ir lapų išmetimas.  
Norėdami pašalinti vieną ląstelę, pažymite norimą pašalinti ląstelę ir einate Edit-> Delete. 

Atsidariusiame dialogo lange galima pasirinkti:  
o Shift cells left - tai reiškia bus šalinama ląstelė (arba blokas), o į tą vietą pasislinks 

ląstelės iš dešinės pusės.  

o Shift cells up - tai reiškia bus šalinama ląstelė (arba blokas), o į tą vietą pasislinks 
ląstelės, kurios yra žemiau šalinamų.  

o Entire row - išsitrins visa eilutė, kurioje yra pažymėtoji ląstelė. Jei bus pažymėtas 
blokas per kelias eilutes, tada išsitrins kelios eilutės.  

o Entire column - išsitrins visas stulpelis.  
Taip yra ištrinamos eilutės ir stulpeliai ir į jų vietą atsistoja kitos reikšmes, priklausomai nuo to kaip 

jūs pasirenkate. Lapų trynimas vyksta labai paprastai. Einate Edit-> Delete Sheet. Jei atsidariusioje lentelėje 
paspausite "OK" aktyvus puslapis bus ištrintas. Jei norite trinti iškart kelis puslapius, paspaudę CTRL 
mygtuką pažymėkite visus norimus ir vykdykite tą pačią komandą. Dėmesio!!! įvykdžius šią komandą, 
veiksmo gražinti atgal nebegalima, komana Undo neveikia.  

Reikšmių ir formatų trynimas.  



Yra kita komanda - Clear, kuri trina tik ląstelėje esančią reikšmę, formatą, komentarą. Ši komanda 
randasi Edit-> Clear. Saktyvinus Clear:  

o All - yra trinami formatai ir esanti reikšmė arba tekstas.  

o Formats - tik formatai, reikšmės, tekstas pasilieka, tik ląstelė pasidaro Default stiliumi.  

o Contents Del - trinama tik reikšmė arba tekstas.  

o Comments - trinamas tik komentaras.  
Eilučių, stulpelių, ląstelių ir lapų įterpimas. 
Šios komandos, savo atlikimu, labai panašios į trynimą. Pradėkime taip pat nuo ląstelės įterpimo. 

Pažymite kurioje vietoji turi atsirasti įterpta ląstelė (arba blokas) ir einate Insert-> Cells... Atsidaro Inset 
dialogo langas. Jame galima pasirinkti:  

o Shift cells right - tai reiškia, kad ląstelė esanti toje vietoje ir visos į dešinę nuo jos bus 
patraukiamos į dešinę pusę.  

o Shift cells down - tai reiškia, kad ląstelė esanti toje vietoje ir visos į apačią nuo jos bus 
patraukiamos į apačią.  

o Entire row - tai reiškia, kad bus įterpiama eilutė, o buvusi patraukiama žemyn. Eilutę 
taip pat galima įterpti ir Insert-> Rows.  

o Entire column - tai reiškia, kad bus įterpiamas stulpelis, o buvęs bus patraukiamas į 
dešinę pusę. stulpelį taip pat galima įterpti ir Insert-> Columns.  
Pastaba: jei prie įterpdami ląstelę pažymėsite ląstelių bloką, tada ir bus įterpimas tokio dydžio ląstelių 

blokas. Jei pažymėtas blokas bus, sakykime per tris eilutes ir du stulpelius, tada: atlikus Insert-> Rows - 
įsiterps trys eilutės, o Insert-> Columns - du stulpeliai. 

Naujo lapo įterpimui naudojama komanda Insert-> Workssheet, ji įterpia standartini MS Excel lapą. 
Jei užlipsite ant esamo lapo ir paspausite dešinį pelės mygtuką, atsidariusiame menių, pasirinkus Insert.. 
atsidarys Browse tipo "Insert.." langas, kuriame bus galima pasirinkti norimą šabloną, na bet apie šablonus 
vėliau.  

 
Spausdinimas su MS Excel programa.  
Visi spausdintuvo nustatymai Ms Excel yra Page Setup dialogo lange,kurį galima iškvieti: File-

>Page Setup. Šiame lange yra keturiuos dialogo kortelės:  
1. Page čia galite pasirinkti lapo orientaciją: Portrait - vertikalus, Landscape - 

horizontalus lapas. Taip pat spausdinimo skalę, kiek procentų tikro dydžio spausdinti arba nurodyti į 
kiek lapų sutalpinti esant tokiam pločio ir aukščio santykiui. Dar galima pasirinkti lapo formatą, 
spausdinimo kokybę ir pirmojo lapo numerį (First page number:).  

2. Margins - viskas apie lapo paraštes. Galite nurodyti jų dydžius, taip pat galite 
pasirinkti, kad lape esantis turinys būtų centruojamas vertikalumo ir/arba horizontalumo atžvilgiu.  

3. Header/Footer - infromacija, kuri bus rodoma viršutinėje Header ir/arba apatinėje 
paraštėje. Galite pasirinkti iš MS Excel siūlomų arba pasidaryti patys, paspaudę mygtuką Custom 
Header ir/arba Custom Footer. Ten galėsite keisti paraštės šriftus, įvesti datą, puslapių skaičiavimą 
laiką, Sheet(puslapio) vardą, laiką ir kitą informaciją.  



4. Sheet čia jūs galite pasirinkti, kokį plotą spausdinti: Print area:. Taip pat galite 
nurodyti eilutes ir stulpelius, kuriuos kartoti kiekvieno lapo viršuje ir kairėje lapo pusėje: Rows to 
repeat at top: ir Columns to repeat at left. Dar galite pasirinkti kas bus spausdinama: Grindlines - bus 
spausdinamos linijos, kurios skiria ląsteles. Black and white - viskas spausdinama tik juoda ir balta 
spalvomis. Draft quality - brėžinio kokybė. Row and column heading - bus spausdinamos raidės 
esančios stulpelių viršuje ir skaičiai ląstelių kairėje. Taip spausdindami ląstelės koordinates galėsite 
sužinoti ir ant atspausdinto lapo. Jos yra kartojamos kiekviename lape. Comments - komentarai. Čia 
dar galima pasirinkti ar spausdinti toje vietoje, kur yra komentaras As displaet on sheet, ar lapo 
apačioje atspausdinti ląstelės koordinatę, kurioje yra komentaras ir tada komentaro turinį At end of 
sheet. Na ir paskutinis parametras, kurį galite pasirinkti tai kokiu eiliškumu sudėlioti lapus. 

Pirma eina į apačią, kai pasibaigia žiūri ar dešinėje pusėje. Down, then over 
 Pirma į dešinę pusę, po to žemyn. Over, then down 

 

 
 
Komentaro Comment įterpimas.  
Komentarai yra naudojami, tada, kada apie reikiamą ląstelę yra reikalinga kokia nors papildoma 

informacija, kuri neturi būti tos ląstelės reikšmė. Pvz.: Excel lentelės viršuje(ląstelėje d1) galime padyri 
ląstelę su formulę =sum(a2:a65356) ir ląstelėje "d1" įterpti komentarą: "Pirmojo stulpelio suma". Tokiu 
atveju užvedus pelės kursorių atsiras užrašas: "Pirmojo stulpelio suma" ir net ne bylos autoriui bus aišku iš 
kur gauta "d1" ląstelės reikšmė. Norint įterpti komentarą, visų pirma reikia pažymėti ląstelę, kurioje norite 
įterpti komentarą, tada: Insert-> Comment. Šalia ląstelės atsiras Text Box su rodykle į jūsų pažymėtą ląstelę. 
Text Box lauke ir rašykite komentarą. Komentaro tekstą taip pat galima formatuoti visais fiziniai formatais, 
t.y. pabraukti, paryškinti, pakeisti spalvą, šriftą ir t.t. Patį komentaro foną taip pat galima formatuoti įvairiais 
fiziniais formatais. Kad gauti komentaro formatavimo dialogo langą, reikia daryti šitaip: Insert-> Edit 
Comment, tada su palės kursoriumi paspausti ant vienos iš kampinių rankenų ir Format-> Comment. Tada 
atsidaro "Format Comment" dialogo langas. 

Svarbu. Pagal nutylėjimą, MS Excel'io opcijose default reikšmė yra uždėta Comment indicator only, 
tai reiškia, kad į ląstelę įterpus komentarą, ląstelės dešiniajame viršutiniame kampe atsiras raudonas 
trikampio formos indikatorius. Jei Tools-> Options-> View pakeisime Comment & indicator, tada matysime 
ir indikatorių ir komentarą (net neužvedus pelės kursoriaus ant ląstelės). Jei pasirinksime None, tada 
nesimatys nei indikatoriaus, nei komentaro, tokiu atveju pasižiūrėti galima tik pakeitus parametrus arba 
paspaudus View-> Comment. 

Kintamas ląstelės formatas.  
MS Excel'is turi galimybę uždėti ląstelei ir kintamą formatą priklausomai nuo ląstelės reikšmės. 

Geriausiai visa tai galima iliustruoti pavyzdžiu. Sakykime, kad mes visa savaitę stebime kokio nors objekto 
temperatūra, kuri svyruoja nuo -10 iki +10. Stebėjimas vyksta nuo pirmadienio iki sekmadienio. Pasidarome 
tokią lentelę:  

 
 

 A B 
1 Pirmadienis -9 
2 Antradienis -7 
3 Trečiadienis +1 
4 Ketvirtadienis -2 
5 Penktadienis +8 



6 Šeštadienis 0 
7 Sekmadienis +1 
8 Vidurkis -1,14286* 

 
*Kad gautume vidurkį į ląstelę "b8" įvedame formulę =average(b1:b7). Dabar mes kiekvieną dieną 

įrašome kokia buvo temperatūra. Mums reikia, kad ląstelės, kurios temperatūra yra minusinė, fonas 
nusidažytų mėlynai, o pliusinės - raudonai. Lygiai taip pat ir su vidurkio ląstele. Pažymime ląstelių bloką 
(b1:b8) ir einame Format-> Conditional Formatting... Atsidariusiame dialogo lange jūs matysite Condition 
1, ten bus pasirinkimo galimybės. Pirmame palikite Cell Value Is, antrame lauke galima pasirinkti sąlyga (jų 
reikšmės išvardintos žemiau), pasirinkite greater than (daugiau už) trečiame lauke įrašykite reikšmę, šiuo 
atveju "0". Tada spaudžiate mygtuką Format... ir nustatote norimą formatą, jei Condition 1 sąlyga yra 
teisinga. Šiuo atveju mes pasirenkame raudoną fono spalvą. Paskui spaudžiame mygtuką Add>>. Ir 
nustatome antrąją sąlygą. Čia sąlyga pasirenkame less than (mažiau už) ir formate pasirenkame mėlyną 
spalvą. Spaudžiame "OK".  

 
  Sąlygų vertimai 

between Intervale, čia reikia įrašyti dvi reikšmes, pirmoji (nuo), antroji 
(iki). Įrašytos reikšmės nepakliūna į intervalą. 

not between Išskyrus nurodytą intervalą. 
equal to Lygu, atitinka "=" 
not equal to Nelygu 
greater than Daugiau už, atitinka ">" 
lees than Mažiau už, atitinka "<"  
greater than or equal to Daugiau arba lygu už, atitinka ">=" 
less than or equal to Mažiau arba lygu už, atitinka "<=" 

 
Iš viso galima surašyti tris sąlygas, t.y. gali būti trys Condition lentelės. Condition 1, Condition 2 ir 

Condition 3. Taigi vienai ląstelei galima pritaikyti iškarto keturis formatus, priklausomai nuo jos reikšmės. 
Keturis todėl, kad vienas formatas yra Default, jis pasilieka jei yra netenkinamas nei vienas Condition. Mūsų 
pavyzdyje apie temperatūras toks atvejis yra, kai temperatūra yra "0", nes "0" nei didesnis už save nei 
mažesnis. Žinoma, mes galėjome "0" priskirti kokiai nors grupei arba didesnei arba mažesnei. Jei mažesnei - 
Condition 2 sąlyga reikėjo pasirinkti less than or equal to , jei didesnei - Condition 1 - greater than or equal 
to.  

 
Skaičiavimas ląstelėse ir funkcijų naudojimas. 
Kiekviena MS Excel ląstelė, gali skaičiuoti. Joje galima atlikti paprastus veiksmus ir rašyti sudėtingas 

funkcijas. Kad priversti ląstelę skaičiuoti jos pradžioje reikia parašyti ženklą "=" ir toliau rašyti norimą 
veiksmą arba funkciją. Pvz.: į ląstelę įveskite tokį turinį: "=15+45", paspaudę Enter matysite "60". Pažymėję 
ląstelę Formula bar- (jei nesimato Formula bar eilutės, eikite Tools-> Options ir srityje Show prie Formula 
bar uždėkite varnelę.)  eilutėje matysite tai ką jūs ir įrašėte. Tai reiškia, kad ląstelės, kurios pradžioje yra 
lygybės ženklas vartotojui rodo ne įvestą turinį, o reikšmę. 

Dabar, pabandykite įvesti ne veiksmų eilutę, o funkciją iš MS Excel funkcijų sąrašo. Kad pamatytume 
skirtumą, pradžiai panaudokime funkciją SUM(). Parašykime taip: "=SUM(15;45)" paspaudę Enter ląstelės 
reikšmę gausime "60", lygiai taip pat, kaip ir pirmuoju atveju. Bendra funkcijos SUM forma yra tokia 
SUM(Number1; Number2; ...;Number30). Apskritai MS Excel'yje visos funkcijos yra rašomos tokia 
forma:  



FUNKCIJA(pirmas_kintamasis_arba_konstanta; 
antras_k_a_konstanta;...;paskutinysis_k_a_konstanta) 

 
Tarp kiekvieno kintamojo (konstantos) yra dedamas ; (kabliataškis). Ląstelėje A1 parašykite 15, B1 - 45, C1 
- =SUM(A1;B1). Tokiu atveju jau gausis dinaminė lentelė, nes keičiant A1 ir B1 reikšmes, automatiškai 
keisis ir C1 reikšmė.Kartai tarp kintamųjų ir konstantų yra dedamas ir dvitaškis (:), tokiu atveju yra 
nurodomas blokas. Pvz.: yra sąrašas skaičių ląstelėse nuo A1 iki A5, galima rašyti: =SUM(A1;A5) ir 
=SUM(A1:A5). Pirmuoju atveju gausime A1+A5, antruoju A1+A2+A3+A4+A5. Taip pat galima ir kaip 
funkcijos kintamąjį (arba konstantą) rašyti ir kitą funkciją. Pvz.: Surašykime bet kokius skaičius stulpelyje 
nuo A1 iki A4 ir tą patį padarykite nuo B1 iki B4(skaičius rašykite skirtingus). Ląstelėje C1 parašykite tokią 
funkciją: =SUM(MIN(A1:A4);MAX(B1:B4)). Tada ląstelėje C1 vienas jūs matysite mažiausios A stulpelio 
ir didžiausios B stulpelio reikšmių sumą.  

 
Funkcijų paaiškinimai.  
Funkcijas galima išsikviesti komanda, Insert-> Function. Jos yra suskirstytos į devynias kategorijas, 

kurias matysite kairiajame Paste Function dialogo lango, lange. Pasirinkus kategoriją All, lange Function 
Name: matysite visas funkcijas, o pasirinkus kategoriją Most Recently Used - matysite paskutines dešimt jūsų 
naudotų funkcijų. Skyrelyje "Skaičiavimas ląstelėse ir funkcijų naudojimas" yra aprašyta funkcijų bendra 
sintaksė: FUNKCIJA(kintamas1; kintamasis2; ....). Apie tai kokius kintamuosius, kokiai funkcijai reikia 
rašyti ir kokį rezultatą gausime ir bus šis skyrelis. Kadangi tokius duomenis lengviausia pateikti lentelėje, tai 
aš juos pateiksiu lentelėje, kurioje pirmame stulpelyje bus funkcijos vardas (Function Name), antrame 
reikalingi kintamieji - ir jų paaiškinimai, trečiame - platesnis paaiškinimas arba(ir) pavyzdys.  

 
Date & Time, data ir laikas. 

DAY() serial_number - datos 
numeris. MS Excel data yra 
skaičiuojama nuo 1900m. 
sausio 1d. šios dienos 
serial_number=1 

Parodo tik mėnesio dieną nuo 1 iki 31. Pvz.: "A1" - 
"2000.12.22", tada =DAY(A1) gausime 22 

Math & Trig, matematika ir trigonometrija. 
ABS() number - skaičius Parodo realų skaičių. Pvz.: ABS(-2) gausime 2. 
FACT() number - skaičius Pvz.: FACT(5) gausime 1*2*3*4*5 = 120 
INT() number - skaičius Išskiria svaikąją skaičiaus dalį. Pvz.: INT(1,987) 

gausime 1. 
PI() ---- Skaičius Pi = 3.14159265358979 
POWER() number - skaičius, power - 

laipsnis. 
Kėlimas laipsniu. Atitinka operatorių (^). Pvz.: 
POWER(12;5) gausime 248832 

PRODUCT() number1... - skaičius galima 
iki 30. 

Skaičių sandauga. Pvz.: PRODUCT(2;3;4) gausime 
24. 

RAND() --- Atsitiktinai sugeneruoja skaičių 0,???????. Jei norite, 
kad jums ląstelėje atsitiktinai sugeneruotu skaičių nuo 
0 iki 100 darykite taip: INT(RAND()*100). Kiekvienu 
bet kokios ląstelės pakeitimu bus generuojmas nuajas 
skaičius. 

ROMAN() number - skaičius, bet ne 
didesnis už 3999. form - forma, 

Paverčia parastą skaičių į romėniškus rašmenis. 



gali buti 0,1,2,3,4, true, false. 
Kuo skiriasi pabandykite patys, 
gal jūs geriau nusimanote apie 
romėniskus skaičius. 

ROUND() number - skaičius. num_digits 
- kiek skaičių po kablelio 1 - 
vienas skaičius po kablelio. 

Apvalina skaičių iki nurodyto tikslumo. Pagal 
matematines taisykles. ROUND(1,5; 0) gausime 2. Jei 
num_digits - 0, tada iki sveiko skaičiaus.  

ROUNDDOWN() 
ROUNDUP() 

number - skaičius 
num_digits - kiek skaičių po 
kablelio. 

Apvaliną skaičių, iki nurodyto tikslumo imdamas 
žemesnį/aukštesnį skaičių. ROUNDDOWN(7,9; 0) 
gausime 7. ROUNDUP(7,1; 0) gausime 8.  

SQRT() number - skaičius. Kvadratinė šaknis. SQRT(16) gausime 4. SQRT(-16) 
gausime #NUM!, reikia daryti taip SQRT(ABS(-16)) 
gausime 4. 

SUBTOTAL() function_num - funkcijos 
vardas, skaičius nuo 1 iki 11, 
plačiau čia. 
ref1..ref29 - ląstelių blokas. 
Galima nurodyti 29. 

Atliekamas veiksmas su ląstelių reikšmėmis, 
priklausomai nuo function_num parametro. Pvz.: 
ląstelėje "A1" - 15, "A2" - 14 SUBTOTAL(9;A1;A2) 
gausime 29. 9 - reiškia SUM, A1 - ref1, A2 - ref2.  

SUM() number1...number30 - 
skaičius 

Sumuoja nurodytus skaičius. Pvz.: SUM(15;13) 
gausime 28. 

SUMIF() range - ląstelių blokas, 
criteria - kriterijus,  
sum_range - sumuojamas 
blokas. 

Sumuoja tik tas reikšmes, kurios atitinka nurodyta 
kriterijų. Pvz.: Ląstelių bloke, "A1:A5" surašykime 
skaičius nuo 1 iki 5. Tada 
SUMIF(A1:A5;">2";A1:A5) gausime 12 (3+4+5). 
Kad būtų aiškiau pabandykime range ir sum_range 
nurodyti skirtingus blokus. Analogiškai bloke "B1:B5" 
surašykite bet kokias reikšmes. Tada 
SUMIF(A1:A5;">2";B1:B5), tokiu atveju bus iš B 
stulpelio sudedomos tos reikšmės, prie kurių A 
stulpelyje reikšmė yra didesnė už 2. 

SUMPRODUCT() array1..array30 - blokas. Veiksmai atliekami tokia tvarka. array1(pirma 
reikšmė)*array2(pirma reikšmė) + array1(antra 
reikšmė)*array2(antra reikšmė) ir t.t. 

SUMSQ() number1...number30 - 
skaičiai. 

Sumuoja, prieš tai kiekvieną dėmenį pakeldamas 
kvadratu. Pvz.: SUMSQ(3;9) gausime 32+92=90.  

SUMX2MY2() array_x - x reikšmės, 
array_y - y reikšmės. 

Atitinka tokią formulę: sum(x2-y2). Pvz.: array_x= 
{4,5}. array_y={2,4}. Excelis atliks tokius veiksmus:
(42-22)+(52-42) 
(16-4)+(25-16) 
12+9=21.  

SUMX2PY2() array_x - x reikšmės, 
array_y - y reikšmės. 

Atitinka tokią formulę: sum(x2+y2). Pvz.: array_x= 
{4,5}. array_y={2,4}. Excelis atliks tokius veiksmus:
(42+22)+(52+42) 
(16+4)+(25+16) 
20+41=61.  

SUMXMY2() array_x - x reikšmės, Atitinka tokią formulę: sum(x-y)2. Pvz.: array_x= 



array_y - y reikšmės. {4,5}. array_y={2,4}. Excelis atliks tokius veiksmus:
(4-2)2+(5-4)2 
(2)2+(1)2 
4+1=5.  

Text, tekstinės funkcijos. 
CHAR() number - skaičius. ANSI kodą paverčia į simbolį. Ląstelėje A1 įrašykite 

skaičių nuo 1 iki 255, pasirinkime 65, o pvz.: Ląstelėje 
A2 =CHAR(A1), A2 gausime raidę "A".  

CLEAN() text - tekstas. Iš teksto išmeta nespausdinamus simbolius. 
Dažniausiai naudojama kartu su kitomis funkcijomis. 
Pvz.: =CLEAN(CHAR(7)&"TEKSTAS"), taip užrašę 
gausime TEKSTAS. (Apie simbolio & naudojimą 
skaitykite ????? 

CODE() text - tekstas. Simbolį paverčia į ANSI kodą. Jei text nurodysite žodį, 
tai pavers pirmą raidę. Pvz.: =CODE("A"), gausime 
65, =CODE("Arabija"), gausime 65. 

CONCATENATE() text1, text2, .... text30 - tekstas Sujungia kelis tekstus į vieną. Pvz.: "A1" - Labas, 
"A2" - vakaras, o "A3" =CONCATENATE(A1;A2), 
gausime Labas vakaras. 

DOLLAR() number - skaičius. 
decimals - kiek skaičių po 
kablelio rodyti. 

Skaitinę reikšmę paverčia į pinigus. Jei jūsų 
kompiuterio settingai yra lietuviški, tai pavers į litus. 
Pridedamas "Lt" ženklas. Pvz.: "A1" - 101,48, "B1" - 
=DOLLAR(A1;2), gausime 101,48 Lt. 

EXACT() text1, text2 - tekstas. Sulygina dvi eilutes tekstų. Atsižvelgiama ir 
dydžiasias ar mažasias raides. Pateikia atsakymus 
TRUE - teisingai arba FALSE - neteisingai. 

FIND() find_text - tekstas kurio reikia 
ieškoti. 
within_text - tekstas kuriame 
reikia ieškoti. 
start_num - nuo kelinto 
simbolio pradėti (nebūtinas, jei 
nieko tai nuo pirmo). 

Ieško nurodyto vieno simbolio, nurodytoje simbolių 
eilutėje ir atsakyma duoda kelintas tas simbolis yra. jei 
simbolis kartojasi kelis kartus, atsakymas pirmesnis iš 
kairės pusės. Pvz.:FIND("m";"Mano mamai") gausime 
6. FIND("m";"Mano mamai";7) gausime 8. Dižiosios 
ir mažosios raidės turi skirtumą.  

FIXED() number - skaičius. 
decimals - kiek skaičių už 
kablelio paimti. 
no_commas - nežinau, bet jis 
nėra būtinas. 

Skaitine reikšmę paverčia į tekstinę. 

LEFT() 
RIGHT() 

text - tekstas. num_chars - 
kiek simbolių, tarpai taip pat 
skaičiuojami. 

Paima iš tekstinės ląstelęs nurodytą kiekį simbolių. 
LEFT - iš kairės, RIGHT - iš dešinės. Pvz.: 
=LEFT("Donatas";2) gauname "Do". 
=RIGHT("Donatas";2) gauname "as".  

LEN() text - tekstas. Suskaičiuoja kiek simbolių sudaro eilutė. Kažkodėl 
rašomas, kad reikalinga tekstinė reikšmė, bet puikiai 
veikia ir su skaitinėmis eilutėmis. Pvz.: 
=LEN("Donatas") gauname 7. Tarpai taip pat 



skaičiuojami. 
LOWER() 
UPPER() 

text - tekstas. Paverčią teksta LOWER - mažosiomis raidėmis, 
UPPER didžiosiomis. Pvz.: =LOWER("DONATAS") 
gauname "donatas", =UPPER("donatas") gauname 
"DONATAS" 

MID() text tekstas, 
start_num - pradinis simbolis,
num_chars - simbolių skaičius.

Paima iš simbolių eilutė norimo ilgio iškarpą. Pvz.: 
=MID("DONATAS";2;4) gausime "ONAT". 

PROPER() text tekstas. Kiekvieno teksto žodžio pirmąją raidę padaro didžiąją. 
Pvz.: =PROPER("DoNataS bRIKAS") gausime 
"Donatas Brikas"  

REPLACE() old_text - senas tekstas. 
start_num - pradžios 
simbolis(skaičius) 
num_chars - simbolių skaičius.
new_text - naujas tekstas. 

Gali pakeisti vieno teksto dalį ar visą tekstą naujo 
tekstu. Pvz.: =REPLACE("Labas";3;1;"Rytas") 
gausime "LaRytasas". "Labas" - old_text, 3 - 
start_num, nurodo, kad reikia keisti pradedant trečiu 
simboliu, 1 - num_chars, parodo, kad keisti tik viena 
simbolį, "Rytas" - new_text, naujas tekstas, kuriuo 
reikia pakeisti, šiuo atveju žodžio Labas, trečią raidę.  

REPT() text - tekstas, 
number_times - kiek 
kartų(skaičius) 

Kartoja tekstą nurodytą kiekį kartų. Galima kartoti ir 
skaičius, bet jie bus suprantami kaip tekstas. Pvz.: 
=REPT("Donatas";2) gausime "DonatasDonatas". 

SEARCH() find_text -ieškomas tekstas , 
within_text - tekstas kuriame 
ieškoti, 
start_num - nuo kelinto 
simbolio pradėti (nebūtinas). 

Atsakyma išveda kelintu simboliu prasideda ieškomas 
tekstas. Pvz.: =SEARCH("Rytas";"Atėjo rytas") 
gausime 7, didžiosios ir mažosios raidės neturi 
skirtumo.  

SUBSTITUTE() text - tekstas,  
old_text - tekstas kuri reikia 
pakeisti, 
new_text - tekstas kuriuo reikia 
pakeisti, 
instance_num - skaicius 
parodantis nuo kelintą junginį 
pakeisti (nebūtinas, pagal 
nutylėjimą 1). 

Skirta tekstinėje eilutėje surasti nurodyta simbolį ar jų 
seką ir pakeisti kitu, nurodytu. Pvz.: 
=SUBSTITUTE("Pirmadienis, 1991m.";"9";"8") 
gausime "Pirmadienis, 1891m.", o 
=SUBSTITUTE("Pirmadienis, 1991m.";"9";"8";2) 
gausime "Pirmadienis, 1989m.".  

T() value - reikšmė. Tikrina ar ląstelėje yra reikšmė ar tekstas. Jei tekstas, 
tai ląstelė lygi nurodytos ląstelės reikšmei, jei skaičius 
ar kintama reikšmė, ląstelė pasilieka tuščia. Pvz.: "A1" 
ląstelė - "Labas", "A2" - 150, "A3" - True, "A4" - 
"True". Tada =T(A1) gausime "Labas", =T(A2) 
gausime "", =T(A3) gausime "", =T(A4) gausime 
"True". 

TEXT() value - reikšmė,  
format_text - teksto formatas 
(pvz.: 0,00Lt). 

Paverčia ląstelės reikšmę į tekstą nurodytu formatu. 
Pvz.: "A1" ląstelė - 52, =TEXT(A1;"0,00Lt") gausime 
"52,00Lt", bet ši reikšmė bus tekstas ir su ja negalės 
atlikti jokių matematinių veiksmų.  



TRIM() text - tekstas. Iš teksto eilutės ismeta nereikalingus tarpus. Labai 
praverčia naudojant su funkcijomis LEFT, RIGHT. 
Pvz.: =TRIM(" Einu    namo ") gausime "Einu namo". 

VALUE() text - tekstas. Teksto eilutę, kurią sudaro skaičiai, paverčia reikšme. 
Jei teksto eilutėje yra simbolių nesiverčiančių į 
skaičius gausite klaidą #VALUE!. Pvz.: 
=VALUE("0,05Lt") gausime 0,05. 

Logical, loginės funkcijos. 
AND() logical1, logical2... - loginės 

sąlygos, gali būti iki 
trisdešimties. 

Reiškia "ir". Duoda atsakymą FALSE/TRUE. Jei visos 
užduotos sąlygos teisingos, tada bus TRUE, jei bent 
viena sąlyga netenkinama arba neteisinga - FALSE. 
Pvz.: =AND(2>1;3<10) gausime TRUE, 
=AND(2>1;3>10) gausime FALSE. 

FALSE() 
TRUE() 

Nėra Duoda reikšme FALSE arba TRUE. Naudojama kartu 
su kitomis funkcijomis, kad reikalinga FALSE/TRUE 
reikšmės. Pvz.: =FALSE() gausime FALSE.  

IF() logical_test - loginis testas,  
value_if_true - reikšmė jei 
loginis testas teisingas, 
value_if_false - reikšmė jei 
loginis testas neteisingas. 

Uždavus loginę sąlygą, pagal jos sprendimą ląstelėje, 
gali būti viena įš reikmių. Pvz.: "A1" - 15, "A2" - 17, 
tada: =IF(A1<A2;A2-A1;A1-A2) gausime 2. Jei "A1" 
ir "A2" reikšmes sukeistume vietomis, vistiek 
atsakymas bus du, nes tada loginė sąlyga bus FALSE 
ir bus atliekamas atvirkštinis veiksmas.  

NOT() logical - loginė sąlyga. Duoda reikšmę TRUE/FALSE. Reiškia neigimą. 
Paimkime IF pavyzdyti ir papildykime funkcija 
NOT(), ir dar šiek tiek pakeiskime reikšmes: 
value_if_false ir value_if_true. 
=IF(NOT(A1<A2);"Sąlyga tenkinama";"Sąlyga 
netenkinama") gausime "Sąlyga netenkinama", nors 
"A1" yra mažiau už "A2".  

OR() logical1, logical2 - loginės 
sąlygos, gali būti iki 
trisdešimties. 

Labai panaši į funkciją AND(), tik OR() reiškia arba. 
Duoda reikšmes TRUE/FALSE. TRUE yra tada, kada 
nors viena sąlyga yra tenkinama. Pvz.: 
=OR(2>1;3<10) gausime TRUE, =OR(2>1;3>10) 
gausime TRUE. 

 
Formulių kopijavimas. 
Iš pirmo žvilgsnio gali pasirodyti, kad jei padarau lentelę, kurioje viename stulpelyje turi būti kitų 

stulpelių suma, tai reikės kiekvienoje eilutėje rašyti =SUM(A1;B1) antroje =SUM(A2;B2) ir t.t., o jei tų 
eilučių 100 ar net 1000. Iš tikro čia nėra jokios bėdos. Padarykite šitaip: Surašykite bet kokius skaičius 
stulpelyje A nuo A1 iki A10, paskui tą patį padarykite stulpelyje B, o stulpelyje C jums reikalinga kiekvienos 
eilutės suma. Tada ląstelėje C1 parašykite =SUM(A1;B1), pažymėkite ląstelę C1. Tada Edit-> Copy arba 
klavišai Ctrl+C. Paskui pažymėkite ląstelių bloką C2:C10 ir Edit-> Paste arba klavišai Ctrl+V. Tokiu atveju 
MS Excel'is pats supras, kad žemiau jūs norite sudėti sekančių eilučių duomenis ir ląstelėje C2 bus 
=SUM(A2;B2), o ląstelė C10 =SUM(A10;B10). Kartais reikia taip, kad kopijuojant ląstelę su formulę į kitą 
vietą, formulės kintamieji nesikeistų o išliktų pastovus. Tokiu atveju ląstelė koordinates reikia atskirti 
simboliais ($), pvz.: SUM($A$1;$B$1). Tada nesvarbu kur jūs kopijuotumėte tą ląstelę, joje visada bus A1 ir 
B1 ląstelių reikšmių suma. Taip pat galima naudoti ląstelių vardus.  



Funkcijų rašymas. 
Į ląsteles rašyti ranka visas kitų ląstelių koordinates, dėti skliaustelius, kabliataškius yra labai 

nepatogu ir aplamai sunku nesusimaišyti tarp tiek daug ląstelių ir jei rašome ilgas funkcijas skliaustelių. 

 
Pirma, norėdami į ląstelę įvesti funkciją, ženklą "=" spauskite ne klaviatūroje o Formula bar juostoje, 

paveikslėlyje "=" mygtukas pažymėtas violetine spalva. Tada rašykite funkcijos pavadinimą ir padėkite 
pirmąjį skliaustelį. Atsidarys langas, kur bus išvardinti tos funkcijos kintamieji (arba konstantos). Prie 
kiekvieno kintamojo eilutės gale bus mygtukas (paveikslėlyje pažymėtas geltonai), kurį paspaudus, jūs savo 
byloje gali nurodyti ląstelę arba bloką, kur yra tas kintamasis (arba konstanta), paskui paspaudus vėl tokį pat 
mygtuką, grįšite į tą patį langą. Taip nurodykite visus kintamuosius, jei kiti yra visada konkretus skaičius 
galima rašyti ir ranka. Tada spauskite OK. Visi skliausteliai ir kabliataškiai bus sudėti kaip priklauso ir jums 
nereikės galvoti: "Kokioje dabar ląstelėje aš įrašiau tą kintamąjį 

Ląstelės vardo įterpimas. 
Kartais vietoje ląstelės koordinačių galima naudoti ląstelės vardą. Kad suteiktume kokiai nors ląstelei 

vardą darome taip: Insert-> Name-> Define..., atsidaro Define Name dialogo langas. Eilutėje Names in 
workbook: rašome vardą (jis negali buti su tarpais ir negali kartotis du tokie pat vardai tame pačiame faile). 
Eilutėje Refers to:, mes matome ląstelės (arba bloko) koordinates, jei jos netinka, paspaudus mygtuką 
dešinėje galima nurodyti kitą ląstelę arba bloką. Parašius vardą, spaudžiame Add, po to OK. Tokiu atveju 
funkcijose naudojant šios ląstelės reikšmę kaip kintamąjį nereikės rašyti jos koordinačių, bet bus galima 
rašyti vardą. Pvz.: A1 pavadinkime dėmuo_pirmas, o B2 - dėmuo_antras, tada C1 ląstelėje galime rašyti taip: 
=SUM(dėmuo_pirmas;dėmuo_antras), ir tos ląstelės reikšmė bus A1 ir B1 reikšmių suma, nepriklausomai 
kur mes nukeltumėme ar nukopijuotumėme ląstelę C1.  

 
Grafikų sudarymas su MS Excel'iu. 
Visų pirma, prieš pradedant darytį bet kokį grafiką, reikia duomenų, pagal kuriuos turi būtį jis 

sudarytas. Duomenys suvesime MS Excel lentelėje. Grafikui padaryti panaudosime Chart Wizard  
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tada pažymėkite visą lentelę (kartu ir antraštinę eilutę) ir paspauskite mygtuką. Atsidarys, Chart 
Wizard dialogo langas, kurį sudaro keturi žingsniai:  

1. Pirmame žingsnyje jūs turėsite pasirinkti grafiko tipą. Standartinėje MS Excel 2000 yra 
14 tipų grafikai, iš kurių kiekvienas tipas dar turi nuo 2 iki 7 sub tipų. (sub-type). Dar galima rinktis ir 
iš Custom Types kortelės, bet turėkite omenyje, kad ten yra standartinio tipo grafikai, tik su 
įvairiausiai pakeistomis spalvomis, legendos, serijos ir t.t. vietomis. Todėl pasirinkus bet kurį iš 
standartinio tipo bus galima padaryti analogiškus, čia jau viskas jūsų fantazija. Taip pat savo sukurtą 
tipą galėsite įtraukti į Custom Types/User-defined sąrašą. Mūsų pavyzdžiui mes pasirinkime tipą 
Column - stulpelinis grafikas ir ketvirtą pagal eilę sub-tipą. Tai reiškia, kad mūsų stulpeliai bus su 3D 
efektu. Na pirmas žingsnis atliktas. Spaudžiame Next > .  

2. Antrame žingsnyje jūs jau išvysite savo grafiko pavyzdį. Šiame žingsnelyje yra dvi 
kortelės:  

a. Data Range - tai duomenų koordinatės. Rašomos su operatoriumi "$" - tai 
reiškia, kad nepriklausomai nuo grafiko vietos juos visada išliks fiksuotos. Pvz.: 
=Sheet1!$A$1:$B$8. Antras kriterijus, kurį galima pasirinkti, tai kaip grafike bus dėstomi 
jūsų lyginami dalykai ar eilute(rows) ar stulpeliu(columns)? Kad geriau suprastumėt uždėkite 
tai ant Rows, tai ant Columns ir stebėkite pavyzdį.  

b. Series - tai yra lyginamojo dalyko pavadinimas ar pan. mūsų atveju tai bus 
Pirmadienis, Antradienis ir t.t. Naudojantis Chart Wizard daugumai grafikų jis Series sudeda 
pats ir priskiria joms teisingus parametrus name - vardas i values - reikšmės. Mūsų atveju 
Name - Pirmadienis, Antradienis ir t.t., o values - 30, 28, 32 ir t.t. Tai ir išeina, kad Serie yra 
Name+Value. Šiame žingsnyje dar galima pasirinkti parametrą Category (X) axis labels: 
galima nurodyti X ašies kategorijas.  
Pasirinkus visus parametrus antrame žingsnyje einame toliau. Next >  
3. Trečiajame žingsnyje galėsite pasirinkti užrašus legendos, reikšmių vietas ir pan. 

Šiame žingsnyje yra šešios kortelės, visose jūs matysite savo grafiko pakitimus pakeitus vieną ar kitą 
parametrą.  

a. Titles - čia galima pasirinkti Grafiko pavadinimą, parametras - Chart Title ir 
ašių pavadinimus, Category (X), (Y), (Z) axis:.  

b. Axes - viskas apie ašių reikšmes. Galima pasirinkti ar rodyti reikšmes prie 
atitinkamos ašies.  

c. Grindlines - tai linijos grafike, kurios padeda lengviau nuvesti akis prie ašies 
parašytos reikšmės. Galima pasirinkti kokiais intervalais rodyti Grindlines prie atitinkamos 
ašies. Major grindlines didesniais intervalais, Minor grindlines mažesniais intervalais. Galima 
pasirinkti ir abu intervalus kartu.  

d. Legend - legenda, jei parametras Show Legend - rodyti legendą, paisrinktas 
galima dar pasirinkti legendos vietą: viršuje apačioje kairėje ir t.t.  

e. Data Labels - duomenų žymuo. Galima pasirinkti ar rodyti grafike reikšmes 
prie stulpelio, taško ir pan. (priklausomai nuo grafiko tipo), ar rodyti šalia spalvos pavyzdį ir 
t.t. Palieku tai išsiaiškinti patiems, nes tai nėra sunku o rašymo tikrai daug.  



f. Data Table - duomenų lentelė. Grafike gali būti rodoma ir lentelė, iš korios 
imami duomenys, tereikia uždėti varnelę prie punkto Show data table. O jei prie punkto Show 
legend key uždėsime varnelę, tai lentelėje matysime ir duomenų spalvos/etiketės atitikmenį.  
    Na grafikas jau beveik padarytas, spauskime Next > ir pereikime į paskutinį žingsnį.  
4. Paskutiniame žingsnyje nurodykite savo grafiko dislokacijos vietą. Ji gali būti As new 

sheet - naujame lape, tokiu atveju įrašykite pavadinimą. As object in: - kaip objektas esamame 
puslapyje, nurodykite kuriame. Spaudžiate Finish.  
Na ir gauname štai tokį grafiką.  

 
Dabar dar galite pabandyti pakeisti reikšmes Ms Excel lentelėje, pamatysite, kad iškart grafikas irgi 

pasikeis. Tai pat grafiką jūs galite visaip formatuoti, pakeisti fono spalvą, šriftus ir pan.  
 
AutoShapes, TextBox  
Visų pirma pasižiūrėkite ar pas jus yra aktyvi Drawing mygtukų juosta, jei ne, eikite View-> 

Toolbars-> Drawing. Atsiras štai tokia juosta: 

 
Norint įterpti "AutoShapes" paspaudžiame mygtuką AutoShapes, ten atsiranda sąrašas grupių: Lines, 

Connectors, Basic Shapes, Block Arrows, Flochart, Stars and Banners, Callouts. Dviejų pirmųjų grupių 
"AutoShapes" negalima paversti į "TextBox". Pasirinkus kokią nors grupę, jūs matote visus tos grupės 
"AutoShapes", pasirinkite, tada paspaudę kairįjį pelės mygtuką veskite pelę, paleidę ir gausite savo norimą 
figūrą. 

Kad formatuoti savo figūra būtų lengviau, Drawing juostoje pasirinkite įrankį Select Object. Norint 
formatuoti objektą, reikia jį pažymėti, tada Format-> AutoShape arba Ctrl+1. Atsidarys Format AutoShape 
dialogo langas su keturiomis kortelėmis.  

1. Color and Lines - spalvos ir linijos.  

a. Fill - čia yra galimybė pasirinkt fono spalvą, o jei prie punkto Semitransparent 
uždėsite varnelę, tada fono spalva bus pusiau permatoma.  



b. Line - čia galima pasirinkti apvadinių linijų storį tipą, spalvą. Jei jūsų 
"AutoShape" iš grupės Connector, čia dar taip pat galėsite pakeisti jo tipą.  

c. Arrows - ši grupė komandų veikia tik tada jei jūsų "AutoShape" yra ne uždara 
figūra, o kreivė su laisvais galais. Čia galite ant kreivės galų uždėti rodykles, pasirinkti jų 
stilių ir dydį. Begin Style|Size - pradžios, End Style|Size - pabaigos.  

2. Size - dydis.  

a. Size and rotate - čia galite nustatyti objekto aukštį Height, plotį Width 
centimetrais (arba kitais matavimo vienetai priklausomai nuo to, kokie pas jus nustatyti 
opcijose) ir pasukimo kampą laipsniais.  

b. Scale - čia esama objekto aukštį ir plotį galite keisti procentaliai. Jei prie 
punkto Lock aspect ratio uždėsite varnelę keičiant aukštį automatiškai keisis plotis ir 
atvirkščiai, t.y. objektą išlaikys proporcijas.  

c. Kitų likusių punktų aš neišsiaiškinau, bet jie man visada buvo uždrausti.  

3. Protection - lygiai taip pat, kaip ląstelės protection, jei varnelė ant Locked uždėta, tai 
tada užrakinus lapą (Sheet) objekto keisti nebus galima.  

4. Properties - čia galima pasirinkti:  

a. Move and size with cells - jei bus pasirinktas šis punktas, tada keičiant ląstelės, 
kuri yra po objektu, dydį, keisis ir objekto dydis.  

b. Move but don't size with cells - jei bus pasirinktas šis punktas, tada objekto 
pradžios taškas liks būtinai tame pačiame stulpelyje ir tiek pat pasitraukęs nuo kairiojo 
stulpelio krašto. Keičiant stulpelio dydį, objekto dydis nesikeičia. Pvz.: jei mūsų objektas 
prasideda stulpelyje "C", tai šalia stulpelio "A" įterpus dar vieną stulpelį, "C" pasislenka į 
dešinę ir tampa "D". Tuo pačiu ir objektas pasislinks į dešinę ir jo pradžia bus stulpelyje "D". 
Eilutėms tai negalioja.  

c. Don't move or size with cells - nesvarbu kaip jūs bekeistumėte ląstelių dydį, 
objektas visada liks toje pačioje vietoje ir tokio pat dydžio.  

d. Prin object - jei čia uždėta varnelė, tada šis objektas bus spausdinamas, jei ne 
tai - nespausdinamas.  

Iš visų "AutoShapes" galima padaryti "TextBox". Pažymime objektą, paspaudžiame dešinįjį pelės 
mygtuką ir pasirenkame Add Text. Tada jau turime "TextBox". Pažymėjus objektą vėl nueikime Format-> 
Format AutoShape. Pamatysite, kad dialogo langas pakito, atsirado trys papildomos kortelės ir kortelėje 
Protection punktas Lock text (atskirai galima pasirinkti, ar užrakinti tik objektą ar tik objekte esanti tekstą).  

5. Font - šioje kortelėje galite pasirinkti įvedamo teksto formatą.  

6. Alignment - galite pasirinkti, kaip bus lygiuojamas įvedamas tekstas. Jei punkte 
Automatic size uždėsite varnelę, tada objekto dydis bus priklausomas nuo įvesto teksto, jei vesite 
teksto papildomai, tada objektas pats automatiškai didės.  

7. Margins - galite nustatyti paraščių dydį nuo viršaus, apačios, kairės ir dešinės. Jei prie 
punkto Automatic uždėsite varnelę, tada paraštės bus minimalios.  



Objektų AutoShapes, TextBox 3D formatavimas ir WordArt galimybės.  
Visų pirma pradėkime nuo paprasto stačiakampio 3D formatavimo. (TextBox formatavimas bus 

lygiai toks pat). Drawing įrankių juostoje pasirinkite įrankį Rectangle ir vesdami paspaudę kairįjį pelės 
mygtuką nupieškite norimo dydžio stačiakampį. Tada, vėl Drawing įrankių juostoje paspauskite mygtuką 3-
D atsadyrys menių langas, kur galima pasirinkti vieną iš 20 stilių. Jai jums nei vienas nepatinka, tada tame 
pačiame menių pasirinkite komandą 3-D Settings..., tada atsidarys tokia įrankių juosta: 

 
Čia savo norimą objektą galėsite ir suformatuoti, kaip tik jums patinka. Mygtukų funkcijos: (iš kairės 

į dešinę)  
1. 3-D On/Off - įjungia ar išjungia 3D.  

2. Tilt Down - Suka objektą į viršų horizontalios ašies atžvilgiu.  

3. Tilt Up - Suka objektą į apačią horizontalios ašies atžvilgiu.  

4. Tilt Left - Suka objektą pagal laikrodžio rodyklę, vertikalios ašies atžvilgiu.  

5. Tilt Right - Suka objektą prieš laikrodžio rodyklę, vertikalios ašies atžvilgiu.  

6. Depth - Galima pasirinkti 3D objekto ilgį. Punktą Infinity galima pasirinkti tik tada, jei 
sekančiame (Direction) punkte yra pasirinktas parametras Perspective.  

7. Direction - Galima nustatyti į kurią pusę kryps 3D objektas (tai yra iš kurios pusės jis 
yra matomas). Taip pat galima pasirinkti ir parametrus:  

a. Perspactive - objektas sueis į perspaktyvą. T.y. jei punkte Depth pasirinksite 
parametrą Infinity jo ilgis bus toks, kol visi kampai sueis į vieną tašką.  

b. Parallel - objekto 3D kampai bus fiksuoti. T.y. jei jus pasirinksite stačiakampį, 
nesvarbu kokį jūs ilgį darytumėte, jis niekada nesusiaurės.  

8. Lighting - Čia galima pasirinkti iš kurios pusės į objektą krinta šviesa ir šviesos 
stiprumą. Bright, Normal, Dim (Ryški, Normali, Tamsi).  

9. Surface - Galima pasirinkti medžiagą iš ko padarytas objektas: Wire Frame, Matte, 
Plastic, Metal  

10. 3-D Color - Galima pakeisti objekto 3D dalies spalvą.  
WordArt, tai daugiau MS Word reikalinga funkcija, bet tuo pačiu įrankiu galima naudotis ir MS Excel 

programoje. Drawing įrankių juostoje paspauskite mygtuką Insert WordArt arba menių Insert-> Picture-> 
WordArt. Iš pateiktų pavyzdžių pasirinkite jums labiausiai patinkantį ir spauskite OK. Tada atsidariusiame 
dialogo lange parašykite tekstą (galite pasirinkti fontą ir jo dydį). Tada vėl OK. Atsiradus tekstui turėtų 
automatiškai atsirasti WordArt įrankių juosta. (jei neatsiras užveskite pelę ant bet kurios WordArt objekto 
vietos, paspauskite dešinį pelės mygtuką ir įvykdykite komandą Show WordArt Toolbar. Atsiras štai tokia 
juosta: 

 



 Šių įrankių pagalba, galėsite įvairiai pakeisti savo WordArt objektą. Mygtukų funkcijos: (iš kairės į 
dešinę)  

1. Insert WordArt - įterpia naują WordArt objektą.  

2. Edit Text - galima pakoreguoti pažymėto WordArt objekto tekstą.  

3. WordArt Gallery - atidaro WordArt galerija, jei jus persigalvojote ir norite pasirinkti 
kitokį WordArt'o šabloną, jūsų parašytam tekstui.  

4. Format WordArt - atidaro Format WordArt dialogo langą. Jis toks pat kai ir 
AutoShape, todėl apie jį atskirai neberašysiu.  

5. WordArt Shape - leidžia pasirinkti vieną (iš 40) Shape (formų), pasirinkus norimą 
formą jūsų užrašas bus įvestas į tą formą.  

6. Free Rotate - Galima objektą vartyti bet kokiu kampu ir bet koki kryptimi, aplink 
centro tašką. (x, y, koordinačių plokštumoje).  

7. WordArt Same Letter Heights - padaro visas raides vienodo aukščio.  

8. WordArt Vertical Text - užrašas pasiverčia vertikaliai.  

9. WordArt Alignment - WordArt teksto lygiavimas.  

10. WordArt Character Spacing - galima pasirinkti atstumus tarp simbolių.  
 

Duomenų rūšiavimas. 
Dažnai į lentelę suvestus duomenis reikia surūšiuoti abėcėlės tvarka, jei skaičiai, tai didėjimo arba 

mažėjimo tvarka. Toks sąrašas yra malonesnis akiai ir jei jis yra atspausdintas ant popieriaus lapo, tada 
žymiai lengviau susirasti jus dominančią informaciją. Paimkime paprastą pavyzdį, sudarykime telefonų 
sąrašą: 

Vardas Pavardė Telefono Nr. Adresas 
Jonas Jonaitis 458974 Architektų 1-14 
Petras Petraitis 598745 Gumbinės 15 
Augustas Milašauskas 322511 Gytarių 18 
Dovydas Ališauskas 666879 Vytauto 17-5 

 
Taip atrodys paprastai suvesti duomenys. Dabar reikia pasirinkti, pagal kokį stulpelį rūšiuosime 

duomenis: pagal vardą, pavardę, telefono Nr. ar adresą. Taip pat mums svarbu, kad nesusimaišytų vardai, 
pavardės ir t.t., t.y., kad Jonas netaptų Petraičiu, o Petras - Jonaičiu ir pan. Einame Data-> Sort... Atsidarys 
Sort dialogo langas. Grupėje Sort by pasirinkite, pagal kurį stulpelį norite surūšiuoti. Priklausomai nuo to, 
kas pasirinkta grupėje My list has, bus jūsų pasirinkimo menių. Jei bus pasirinktas parametras Header row, 
tada sąraše bus išvardinta (Vardas, Pavardė, Telefono Nr., Adresas), jei Non header row - (Column A .... 
Column D) ir tada pavadinimai taip pat bus surūšiuojami. Grupėje My list has galimos dvi parinktys:  

1. Header row - yra antraštinė eilutė.  

2. Non header row - nėra antraštinės eilutės.  
Toliau reikia pasirinkti ar rūšiuoti mažėjančia ar didėjančia tvarka. Ascending - didėjančiai arba nuo 

(A iki Ž), Descending - mažėjančiai arba nuo (Ž iki A). Paspaudus mygtuką Options atsidaro Sort Options 



dialogo langas. First key sort order - galima pasirinkti, kad rūšiavimas būtų pagal: mėnesius ar savaitės 
dienas. Nes sakykime jei jūsų sąrašas yra pirmadienis antradienis ... sekmadienis, jums nieko gero jei bus 
sudedama pagal abėcėle. Tada pasirinkite pagal savaitės dienas ir bus pirma pirmadieniai, paskui antradieniai 
ir t.t. Grupėje Orentation galite pasirinkti lentelės orientaciją: iš dešinės į kairę arba iš viršau į apačią. Bet 
paprastai rūšiuojant sąrašus yra naudojamas mygtukas iš pagrindinės įrankių juostos Sort Ascending arba Sort 
Descending. Naudojantis tais mygtukais nereikia žymėti visos lentelės, užtenka tame stulpelyje, pagal kurį 
rūšiuojate, padaryti aktyvią vieną ląstelę ir tada duomenys neišsiskaido, o eilutė yra interpretuojama kaip 
įrašas. Taigi atrodo tiek apie rūšiavimą. O Surūšiuota telefonų sąrašo lentelė atrodytų šitaip: 

Vardas Pavardė Telefono Nr. Adresas 
Augustas Milašauskas 322511 Gytarių 18 
Dovydas Ališauskas 666879 Vytauto 17-5 
Jonas Jonaitis 458974 Architektų 1-14 
Petras Petraitis 598745 Gumbinės 15 

 
Duomenų filtravimas. 
Jei jūs turite lentelę su dideliu duomenų sąrašu, kartais prireikia matyti duomenys, kurie atitinka tam 

tikrą kriterijų. Pvz.: lentelėje, kur yra surašyti darbuotojų atlyginimai, jums reikia pamatyti tik tą sąrašą, kurių 
atlyginimai yra 430Lt. Tokiu atveju jums prireiks stulpelyje atlyginimas uždėti filtrą equal "=" 430Lt.  
Filtro naudojimui MS Excel yra komanda, Data-> Filter-> AutoFilter. Prieš ją paleidžiant reikia žinoti, ar 
jums reikės filtruoti tik pagal vieno stulpelio duomenys ar gali prireikti kriterijų ir iš kelių stulpelių:  

a. Jei užtenka vieno stulpelio - tada pažymėkite ląstelių bloką, tame stulpelyje (būtinai 
paimkite antraštinę eilutę) ir įvykdykite komandą AutoFilter.  

b. Jei filtruoti teks pagal kelis stulpelius - tada pažymėkite reikiamų stulpelių antraštines 
eilutes ir įvykdykite komandą AutoFilter.  

c. Jei jūs nežinote pagal kelių stulpelių kriterijus jums teks filtruoti, tada paprasčiausiai 
pažymėkite bet kokią ląstelę, lentelėje, kur yra jūsų duomenys. Tokiu atveju AutoFilter indikatorius 
užsidės ant visų stulpelių antraštinių eilučių.  
Norint filtruoti duomenis, reikia paspausti indikatorių norimo stulpelio viršuje. Tada atsidaro visų to 

stulpelio reikšmių sąrašas (sudėtas abėcėlės arba didėjančia tvarka). Jei jums reikia konkrečios reikšmės, ją 
pasirenkate ir paspaudžiate pelės mygtuką. Tada jau matysite tik tuos įrašus, kurie atitinka jūsų nurodyta 
kriterijų. Stulpelio, pagal kurį bus atfiltruti duomenys, indikatorius pakeis spalvą, jei Windows Seting'ai 
default, tada pamėlynuos. 

Stulpelio reikšmių sąraše yra užrašai (All), (Top 10...), (Custom...). Apie kiekvieną iš jų:  
1. All - reikalingas tada, kada duomenys yra atfiltruoti ir jums vėl reikalingas pilnas 

sąrašas.  

2. Top 10... - jis veikia tik tada jei to stulpelio reikšmės yra skaitinės. Galima pasirinkti 
įrašų skaičių (skaičiumi - Items, procentais - Percent) ir ar didžiausius (Top), ar mažiausius (Buttom) 
įrašus atrinkti.  

3. Custom... - paspaudus atsidaro Custom AutoFilter dialogo langas. Yra dvi eilutės, 
kurios turi po du įvedimo laukus. Tiek pirmoje, tiek antroje eilutėje kairiajame lauke reikia pasirinkti 
sąlygą, o dešiniajame reikšmę. Abi eilutės yra susietos logine sąlyga And - "ir" arba (priklausomai 
nuo jūsų pasirinkimo) Or - "arba". Plačiau apie šių sąlygų naudojimą skaitykite skyrelyje "Loginių 
sąlygų naudojimas". Kairiojo lauko sąlygų reikšmes žiūrėkite žemiau pateiktoje lentelėje. 



Dešiniajame lauke galima pasirinkti reikšmę iš esančių arba jei sąlyga yra, pvz is less than - mažiau 
už, įrašyti reikšmę, už kurią turi būti mažesnė. Jei stulpelio reikšmės yra ne skaičiai o žodžiai, tada 
sąlygu naudojimu vargu jūs ką ar pasieksite, nes juk žodis negali būti "<" arba ">", o tik "=". 
Filtruojant žodžius galima naudoti simbolius: * - bet koks kiekis, bet kokių interpretuojamų simbolių, 
? - atitinką vieną bet kokį simbolį (pvz.: parašius d????, gausime visus žodžius susidedančius iš 
penkių raidžių ir prasidedančius raide "d", o parašius d*, gausime visus žodžius prasidedančius raide 
"d").  

  Sąlygų vertimai 
equals, does not equal Lygu, nelygu1 
is greater than  Daugiau už2 
is greater than or equal to Daugiau arba lygu2 
is lees than Mažiau už2 
is lees than or equal to Mažiau arba lygu2 

begins with, does not begin with Prasideda nurodyta raide, prasideda ne nurodyta 
raide3 

ends with, does not end with Baigiasi nurodyta raide, nesibaigia nurodyta raide3 

contains, does not contain Žodyje yra nurodyta raidė, žodyje nėra nurodytos 
raidės3 

 
1 tinka ir skaitiniams, ir žodiniams duomenims. 
 2 - tinka tik jei duomenys yra skaičiai. 
3 - tinka jei duomenys yra žodžiai. 
 
Duomenų įvedimo formos naudojimas.  
Ms Excel'io lentelė gali turėti ir duomenų bazės pavidalą. Jis turi netgi turi galimybė išsaugoti failą 

*.dbf ir kitais duomenų bazių formatais. Jei jūsų failas turi duomenų bazės struktūrą (lentelės viršuje gali būti 
įvairiausi užrašai ar pagražinimai), tada duomenims suvesti yra labai patogu naudoti formą Form, ypač, jei 
jūs lentelėje naudojate formules ir lentelė nuolat yra papildoma naujais įrašais. Na kaip ir daugelį dalykų, taip 
ir formos naudojimą geriausiai bus aprašyti pavyzdžiu. Sakykime, kad mes pardavinėjame daržoves ir 
kiekvieną pardavimą fiksuojame MS Excel'io lentelėje. Lentelę sudaro keturi stulpeliai: Pavadinimas, 
Kiekis, Kaina ir Suma. Paprastai vedant su pirmais trimis stulpeliais taip pat nebūtų jokių problemų, bet 
paskutiniame stulpelyje mums reikalinga Kiekis*Kaina. Kiek daržovių per tam tikrą laikotarpį parduosime, 
mes nežinome, todėl kopijuoti formulę yra nenaudingą ir be to jei naudosime paprastą sandaugą, kol eilutės 
nebus pilanai užpildytos mes matysime 0. Naudojant Form šios problemos galima išvengti. Pirmoje eilutėje 
surašykite stulpelių pavadinimus. Antroje eilutėje gausi pirmasis jūsų įrašas, jį teks parašyti nesinaudojant 
įvedimo forma. "A2" - įrašykite "Pomidorai", "B2" - 2, "C2" - 8,99 ir "D2" - =B2*C2, gausime 17,98. Dabar 
norint pildyti lentelę toliau aktyvuokite bet kurią ląstelę, kuri papuola į užpildytos lentelės bloką ir 
aktyvuokite komandą: Data-> Form.... Jums atsidarys Štai tokia forma: 



 
Joje ir veskite tolimesnius duomenis. Kaip pastebėjote, stulpeliui Suma duomenų įvesti negalima, 

kadangi, jie yra gaunami kaip kitų dviejų stulpelių sandauga. Pačiame formos viršuje matysite, kiek yra šiuo 
metu įrašų ir kelintas yra rodomas formoje. Norėdami papildyti spauskite mygtuką New, ištrinti Delete, 
vaikščioti per įrašus, galima su rodyklėmis aukštyn žemyn, ir jei norite eiti tik žemyn su ENTER. Taip pat 
galima naudoti mygtukus Find Next, Find Prev. Formos antraštė priklauso nuo Sheeto (puslapio) 
pavadinimo. Kaip jūs jį pavadinsite, tokią antraštę ir matysite Formos viršuje. Formai uždaryti paspauskite 
mygtuką Close, formoje arba ESC klaviatūroje. Na tai tiek apie formas. Formoje taip pat yra mygtukai 
Criteria ir Restore (jis uždraustas), bet apie jų naudojimą deja aš nieko nežinau. 
 

 
Macro komandos. 
MS Excel'is - turi tikrai puikią funkciją, tai yra Macro komandų įrašinėjimą. Macro komanda - tai tam 

tikram objektui priskirtas poprogramis Visual Basic kalba. Kaip pasidaryti macro komanda ir kokia mums iš 
to nauda. Nauda yra tame, kad jei mums dažnai tenka kartoti kokius nors veiksmus, mes galime padaryti taip, 
kad vienu paspaudimu MS Excel'is tai atliktų pats. Na pvz.: dažnai pildome lentelę, kurią atsispausdiname 
ištriname iš juos duomenis ir vėl pildome naujais. Kad nereikėtų visada trinti patiems, pasidarykime tokią 
macro komandą, kuri trina jūsų lentelės duomenis. Macro komandos įrašymą sužadinsite įvykdę komandą 
Tools-> Macro-> Record New Macro... Atsidarys Record Macro dialogo langas, ten Macro name: 
pasirinkite macro komandos vardą, jis gali būti bet koks žodis, tik negali būti tarpų ir turi prasideti raide. 
Shortcut key: pasirinkite klavišų kombinaciją, kuriai priskirsite macro komandą. Store macro in: - galite 
pasirinkti ar šią macro komandą naudosite tik šiame dokumente(This Workbook), ar norite, kad ją galėtumėte 
priskirti bet kokiam objektui ir kituose MS Excel dokumentuose (Personal Macro Workbook), ar ruošite 
macro komandą naujam dokumentui (New Workbook). Description: galite parašyti papildomą informaciją, 
ten turėtų būti įrašyta data, ir autorius, kuriuo vardu yra priregistruota MS Excel programa.kai 
viską surašėte spaudžiate "OK". Atsiras tokia įrankių juosta: 

Tada reikia atlikti visus veiksmus, kuriuos norite, kad vėliau atliktų pats kompiuteris. 
Viską darykite neskubėdami ir apgalvotai, nes tuo laiku, kai jūs darysite, visus jūsų veiksmus MS 
Excel'is užrašinės tam tikrame modulyje Visual Basic programavimo kalba. Jei jūs kur nors suklysite ir 
klaidą atitaisysite, tai macro komanda taip ir užsirašys ir ją vykdant taip pat bus suklysta ir klaida ištaisyta. 



Geriau stengtis neklysti, nes tada poprogramio kodas bus mažesnis ir jis bus vykdomas greičiau. Baigus viską 
daryti paspauskite mygtuką "Stop" ant atsiradusios įrankių juostos. Tada belieka sukurtą macro komandą 
priskirti kokiam nors objektui. Pvz.: Pasirinkime TextBox, su užrašu trinti lentelę. Ant objekto paspauskite 
dešinįjį pelės mygtuką ir atsiradusiame menių pasirinkite komandą Assign Macro. Atsidariusiame lange 
matysite savo sukurtos macro komandos pavadinimą, ant jo ir bakstelkite pele, tada "OK" ir viskas, macro 
komanda priskirta šiam objektui. Dabar paspaudę su pele ant TextBox įvykdysite savo sukurtą macro 
komandą. 

 Svarbu. Išsaugojus failą ir jį atidarant sekantį kartą MS Excel'is praneš, kad šiame faile yra macro 
komandų ir vadinasi šis failas gali būti užkrėstas virusu. Jei jūs pats darėte šią makro komandą arba žinote, 
kad žmogus davęs šią bylą jūsų tikrai nenori apkrėsti virusais spauskite mygtuką Enable macros, jei ne tada 
Disable macros, bet antruoju atveju macro komandos faile neveiks. Jei naudojate MS Excel 2000 ir nenorite, 
kad kiekvieną kart atidarinėjant failą su macro komandomis apie tai būtų pranešama, tada eikite Tools-> 
Macro-> Security.. ir Security Level pasirinkite Low.  

 
Forms elementų naudojimas.  
Pirmiausiai reikia įsijungti įrankių juosta su Forms elementų rinkiniu. View-> Toolbars-> Forms 

Atsiras štai tokia įrankių juosta: 

 
Kaip ir bet kuris objektas, taip ir forms elementas turi savo Properties dialogo langą. Visos kortelės 

kartojasi, kaip ir kitose objektuose, tik Forms elementai turi dar vieną kortelė - Control. Joje ir yra viskas kas 
mums bus reikalinga. Objektai Label, Toggle Grid,Button ir Control Properties - Control kortelės neturi. 
Tiesa Toggle Grid išvis nėra objektas. Norint iškviesti Forms objekto Properties dialogo lango kortelę 
Control, reikia pažymėti objektą ir paspausti mygtuką Control Properties. MS Excel 2000 versijoje, objekto 
Group Box Prperties langas su mygtuku neišsikviečia, reikia paspausti dešinįjį pelės mygtuką ir aktyvizuoti 
komandą Format Control...  

 
- Label. Su šiuo įrankiu galite nustatyti plotą, kuriame galite įvesti tekstą. 

 
- Group Box. Skirtas sugrupuoti Forms objektus į grupes. Control yra pasirinkimas 3D shading. 

Galima uždėti 3D šešėlį.  
 

- Button. Mygtukas, skirtas vygdyti Macro komandoms. Jį įterpus į lentelę iškart atsiranda Assign 
Macro dialogo langas. 

 
- Check Box. Naudojamas, kada reikia pasirinkti kelis kriterijus iš pateiktų sąrašo. Gali įgyti reikšmes 

TRUE/FALSE/#N/A. Control - galima pasirinkti kokia reikšmė bus pradinė: Unchecked - FALSE, Checked - 
TRUE ir Mixed - #N/A. Cell link - nurodykite ląstelę į kurią bus išvedama reikšmė. Na šiam objektui dar taip 
pat galima uždėti ir 3D šešėlį. Jei naudojate kelis objektus kiekvienam Cell link reikia nurodyti skirtingą 
ląstelę.  

 
- Option Button. Naudojamas tada, kai iš pateiktų kriterijų grupės galima pasirinkti tik vieną. Įgyja 

reikšmes 1, 2, ... Sakykime jei naudojate tris Option Button, tada jei pirmas bus Checked - tai ląstelėje, į kurią 
bus nurodyta parametru Cell link gausime reikšmę 1, jei antras - 2 ir jei trečias - 3. Vienos grupės Option 
Button Cell link turi butį tas pats. Pirmąjam nustačius kitų nusistato automatiškai. Jei viename puslapyje 
norite naudoti ne vieną kriterijų, pasirenkamų su Option Button, tada būtina naudoti Group Box objektą. 



 
- List Box. Naudojamas kai iš sąrašo reikia pasirinkti vieną kriterijų. Control - Input range, reikia 

nurodyti ląstelių bloką (stulpelį arba eilutę), kuriame surašyti kriterijai. Cell link - ląstelė, kurioje bus 
išvedama reikšmė priklausomai nuo pasirinkimo. Input range esantis sąrašas paeiliui įgyja reikšmes 1, 2 ir t.t. 
T.y. jei bus pasirinktas pirmas kriterijus, tai reikšmė bus 1, jei dešimtas - 10. Selection type Single, Multi ir 
Extend. Deja aš čia aprašiau tik Single tipą, o apie kitų tipu naudojimą aš nieko parašyti negaliu.  

 
- Combo Box. Naudojimas praktiškai toks pat kaip ir List Box. Control - viskas tas pats kaip ir List 

Box, išskyrus nėra Selection type ir yra Drop down lines - šiuo parametru nusistato kiek eilučių žemyn turi 
matytis nenaudojant scrollbar'o.  

 
- Scroll Bar. Vertikalus Scroll Bar'as. Control:  

1. Current value - dabartinė reikšmė.  

2. Minimum value - minimali reikšmė.  

3. Maximum value - maximali reikšmė.  

4. Incremental change - per kiek +- turi pasikeiti reikmė paspaudus apatinį arba viršutinį 
scrollbar'o mygtukus.  

5. Page change - per kiek +- turi pasikeisti reikmė paspaudus pelės mygtuką, pelės 
žymekliui esant ant tuščios scrollbar'o vietos.  

6. Cell link - ląstelė, kurioje yra išvedama reikšmė.  
   Galimos reikšmės nuo 0 iki 30000. 

 
- Spinner. Naudojimas ir lygiai toks pat kaip Scroll Bar. Control visi parametrai tokie pat tik nėra 

Page change. Galimos reikšmės nuo 0 iki 30000.  
 

- Control Properties. Iškviečia pažymėto objekto Properties dialogo lango kortelę Control.  
 

- Toggle Grid. Skirtas išjungti ir įjungti MS Excel'io lentelės nespausdinamas linijas (Gridlines). 
 
Ląstėlių reikšmių patvirtinimas Validation  
 
Būna taip, kad į tam tikras ląsteles reikia vesti tik teigiamus arba iš tam tikro intervalo skaičius, 

žodžius, kuriuos sudaro būtent norimas skaičius raidžių ir pan. Tam yra skirta komanda Data-> Validation. 
Ten galima nustatyti, kokias reikšmes galima įrašyti į tam tikras ląsteles, ką daryti jei reikšmė neteisinga, taip 
pat galima padaryti informacinį langą, kuris atsiranda suaktyvinus ląstelę. Įvykdžius komandą Data-> 
Validation atsidarys Data Validation dialogo langas, su trimis kortelėmis: Settings, Input Message ir Error 
Alert  

1. Settings - galima nustatyti patvirtinimo kriterijus, tik šiuos kriterijus atitinkančios 
reikšmės bus galima rašyti į ląstelę. Jei prie Ignore balnk nuimsite varnelę, tada tuščia ląstelė taip pat 
neatitiks jūsų kriterijų, priešingu atveju tuščią ląstelę palikti galima. Allow (sutikimo sąlygų) reikšmes 
žiūrėkite žemiau pateiktoje lentelėje. Parametru Data galima pasirinkti loginę sąlygą <> ir 
pan.(Žiūrėti čia). Priklausomai nuo antrojo ir trečiojo parametrų pasirinkimo atsiranda du arba vienas 
įvedimo laukai. Čia reikia įvesti formulę, minimalią ir (arba) maksimalią reikšmes, skaičių, nurodyti 



ląstelių bloką ir pan. Jei lygiai tokį patį ląstelių patvirtinimą priskiriate ląstelių blokui ir paskui 
nusprendžiate jį šiek tiek pakeisti, tada padarius pakeitimus reikia prie punkto Apply these changes to 
all other cells with the same settings uždėti varnelę ir prie ląstelių esančių su vienodais tvirtinimo 
parametrais jie pasikeis automatiškai, net nereikia pažymėti viso ląstelių bloko.  

2. Input Message - čia galima padaryti pranešimo langą, kuris atsiras pažymėjus ląstelę. 
Prie punkto Show input message when cell is selected reikia uždėti varnelę, tada Title dalyje įrašyti 
antraštę, o Input message - žinutės tekstą. Jei nenorite, kad būtų rodomas parašytas tekstas reikia 
Show input message when cell is selected varnelę nuimti. Jei teksto nebuvote parašę, varnelė gali ir 
pasilikti, tuščias pranešimas nėra rodomas.  

3. Error Alert - čia galite sukurti pranešimo langą, kuris atsiras jei duomenys bus įvesti 
klaidingai, tai yra neatitiks setings dalyje nustatytų kriterijų. Style dalyje galima pasirinkti kokios 
rušies bus pranešimas: 

- stop stiliaus langas. Jame bus Retry ir Cancel mygtukai. Paspaudus pirmąjį galėsite 
bandyti įvesti dar kartą, o paspaudus antrąjį pasiliks buvusi reikšmė. Neatitinkančios kriterijų 
reikšmės įvesti niekaip nepavyks.  

- warning stiliaus langas. Jame bus Yes/No/Cancel mygtukai. Paspaudus Yes jūs galėsite 
palikti duomenis neatitinkančius nurodytų kriterijų. No - galėsite vesti duomenis iš naujo ir 
Cancel - pasiliks buvusi reikšmė.  

- information stiliaus langas. Jame bus Ok/Cancel mygtukai. Šis langas skirtas tik išvesti 
informacijai apie tai, kad duomenys neatitinka jūsų nurodyto kriterijaus, bet paspaudus bet 
kurį mygtuką duomenys pasilieka tie kuriuos jūs įvedėte, tik skirtumas tas, kad paspaudus 
Cancel pasilieka aktyvi ta pati ląstelė, o Ok pereinama viena ląstele žemiau. 

Languose Title ir Error message veskite atitinkamai antraštę ir pranešimo tekstą.  

Allow (tvirtinimo, sutikimo) reikšmių paaiškinimai.  
Any value Kriterijus atitiks bet kuri reikšmė. 
Whole number Į tokią ląstelę bus galima rašyti tik skaitines reikšmes, kurios 

atitiks Data parametrus. Tekstinės reikmės į šią ląstelę rašyti 
nebus galima. 

List Bus galima įrašyti tik tokia reikšme, kurios bus surašytos jūsų 
sąraše. sąrašas gali būti nurodytas kaip ląstelių blokas. Jei 
prie punkto In-cell dropdown uždėsite varnelę, tada net 
nereiks rašyti reikšmių ranka, o pažymėjus ląstelę atsidarys 
dropdown menių ir galėsite pasirinkti reikšmę iš sąrašo. 

Date/Time Galima nurodyti datos/laiko intervalą, datą/laiką supranta 
rašant bet kokiu formatu. Į tokią ląstelę galima rašyti skaičius, 
bet teksto rašyti taip pat neišeis. 

Text length Galima nustatyti kelių simbolių turi būti reikšmė. 
Custom Galima įrašyti formulę, kurią turi tenkinti reikšmė. 
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