Programos paleidimas Start-> Programs-> Microsoft Excel.
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o Lentelés kursorius — paryskinty linijjy rémelis darbo lentel¢je, kuris Zymi aktyvuy, parengta
duomeny raSymui, ekrane rodomos lentelés langeli.

e Valdymo komandy meniu - pele arba funkciniais valdymo klaviSais parenkamy paketo valdymo
komandy vardy sarasas arba komandas vaizduojanciy zenkliuky rinkinys.

¢ Jvedimo laukas — ekrano eiluté tarp valdymo komandy Zenkliuky juostos ir darbo lango, kurioje yra
rodomi aktyvaus langelio saugomi arba i ji ivedami duomenys.

¢ Valdymo Zenkliuky meniu - pele parenkamy valdymo komandy grafiniy ivaizdZiy juosta.

e Darbo lenteliy parinkimo Zymés — { darbo langa siunc¢iamy darbo knygos lenteliy parinkimui
skirtos zymes.

¢ Informacinis laukas — ekrano dalis su duomenimis apie paketo darbo rezima ir tvarkomo
dokumento savybes.

e Procesy konstruktorius (Wizard) — dialoginé paketo valdymo priemoné, kuri siiilo vartotojui

tipiniy lenteliy tvarkymo darby organizavimui skirta komanduy seka ir konsultuoja apie ty veiksmy valdymo

budus.

Paciame virSuje, kaip ir daugelyje Windows terpés programy, yra meniu eiluté, truputi Zemiau
standartiné irankiy juosta, na o dar Zemiau turéty biiti formulés juosta Formula Bar. Toliau prieiname prie
pacios Excel lentelés. Ji yra sudaryta i$ lasteliy cells, kurios yra graziai surikiuotos { stulpelius columns ir
eilutes rows. Kairéje ekrano pus¢je yra vertikaliai sunumeruotos eilutés (nuo 1 iki 65536), o virSuje -
horizontaliai stulpeliai (nuo A iki IV). Kiekviena Iastelé turi savo koordinates, eilutés ir stulpelio atzvilgiu.
Pvz.:



| A1 | B1 | c1 |
| A2 | B2 | c2 |

Nurodant lasteliy koordinates ir yra susiejamos lastelés viena su kita. Suaktyvinus lastele, jos
koordinatés yra rodomos kairéje formulés juostos pus¢je, vadinamoje vardo dézutéje name box.

Puslapiai Sheet

Pacioje lentelés apacioje yra Excel'io puslapiai, kurie pagal nutyl¢jima biina trys arba keturi
(priklausomai matyt nuo versijos). Yra tokios kortelés su uzrasais: Sheetl, Sheet2.... Juos galima pervardinti
ir jterpti. Puslapiai Sheet labai pravercia tada, kada reikia suvesti daug duomeny i§ kuriy yra gaunami
konkrettis rezultai, juos perkeliame i kita puslapi, kurj paruoSiame taip, kad biity patogu spausdinti.

Lastelés fomatai

MS Excel programos lastelé turi gana nemazai fiziniy formaty.

Format Cells B

Murnber | Alignment | Font | Border | Patterns | Protection

General -

Categony: ’rSampl ‘
MNurrber

(o] |
Cancel |

Currency

Accounting Decimal Flaces |2 3‘

Date

Time ™ se 1000 Separatar ()

Fercentage . :

Fraction MNegative Mumbers:

Scientific -

Text 123410

Special -1234.10

Custarn 123410 =
| /|

Murnber is used for general display of numbers. Currency and Accounting offer
specialized formatting for monetary values.

Juos visus keisti galima taip: pazyméjus lastele ar ju bloka Format-> Cells..(arba Ctrl+1) ir ten
atsidaro atsidariusiame lange yra SeSios kortelés, apie kurias toliau ir kalbésime:

1. Pirmoji kortelé su pavadinimu Number. Joje galima lastelei priskirti kategorija. Lauke
Category yra iSvardintas kategorijy sarasas: General, Number, Currency ir tt...

a. General - tai standartinis lastelés formatas, jei tai bus tekstas, jis bus raSomas
nuo kairiojo krasto, jei skaiCius tai deSiniame, jei irasysite data, ji bus tokiu formatu, kokiu
paraSysite, bet Excel'is, supras, kad tai yra data.

b. Number - galima nurodyti kiek skai¢iy po kablelio rodyti, (laukas Decimal
place). Jei prie punkto Use 1000 Separotor (.) uzdésite varnelg, tada skaiciai kas tukstantoji
dalis bus atskiriami (.), pvz.: 1000 atrodys Sitaip 1.000. Lauke Negative numbers galima
pasirinkti kokia spalva rodyti teigiamas ir neigiamas reikSmes.

c. Currency - galima priskirti kokios nors Salies valiutos simbolj. Jei priskirsime
litus, tai toje lastel¢je automatiSkai bus rodomas skaicius kuri paraSysite ir prisidés simbolis
LT. Taip kaip ir ankstesniame punkte galima pasirinkti skai¢iy po kablelio kieki ir teigiamy
neigiamy reikSmiy spalvas.

d. Accounting - jis taip pat prideda piniginio vieneto simbolj.

e. Date - tai datos formatas. Lastel¢je, kurioje uzdétas toks formatas, turi buti
raSoma data. Jei jiis ten paraSysite skai¢iy MS Excel ji pavers | data. Kokiu tipu rodyti data,



galima pasirinkti lange Type. Kaip Excel'is pavercia skaiCiy | data? Paimkime ant lastelés
uzdékite formata Date ir pasirinkite tipa, kad rodyty ménesio pavadinima, diena, metus. Tada
toje lasteléje irasikite skaiCiy 36526. Tokiu atveju gausite: sausis 1, 2000. MS Excel
skai¢iuoja kiek dieny praéjo nuo 1900.01.01 (imtinai). ParaSius vieneta gautume: sausis 1,
1900

f. Time - tai laiko formatas. Si kategorija labai panasi i Date, jos net siejamos,
tipuose galima pasirinkti, kad rodyty data ir laika. Sis formatas lygiai taip pat ver¢ia skaiiy i
laika. Tik laikas yra skaiCius po kablelio, t.y. kokia dalis paros. Pvz.: viena valanda yra
0,0416666... paros. Tokiu atveju pasirinkus tipa, kur yra rodomas laikas, bet nerodoma data ir
parasius 0,0416666, matytume 1:00.

g. Percentage - Sioje lasteléje bus raSomi procentai. Prie skaiciaus bus
pridedamas zenklas "%" ir iraSytas skaicius automatiskai ver¢iamas i procentus.

h. Fraction - §is atributas skaiCius vercia | trupmenas. Pirmi trys atributai vercia
tiksliai kokia yra, tik galima pasirinkti trupmenos dydi ta prasme i kiek skaic¢iy po kablelio
atsizvelgti lik¢ atributai, taip pat, tik skirtingu tikslumu apvalina. Pvz.: parasius 1,5 gausime 1
1/2.

1. Scientific - lastelélé su tokiu atributu jisy ijrasyta skaiiy rodys Sitaip:
1,00E+01. Decimal place pasirinktas skaiCius reiskia kiek zenkly po kablelio rodyti. Kam tai
reikalinga? Tai reikalinga tada, kai tenka raSyti ypatingai ilgus skaicius, kad jie matytus néra
butina, sakykime mums reikalinga tik tokiy skai¢iy suma. Tokiu atveju lasteléje, kurioje bus
suma, pasirinksime atributa Number ir matysime visa skaiciy. O lasteléje 1 kurig vesime
matysime taip pvz.: ivedame 123456789, lasteléje bus taip: 1,23E+08, tai reiskia, kad skai¢ius
prasideda 123... ir nuo kablelio dar yra aStuoni sveiki skaitmenys.

J- Text - tai tiesiog lastelé skirta rasyti tekstui, nors ten rasysite ir skaicius, bet
excel'is juos supras kaip teksta.

k. Special - yra keturi formatai, tai ZIP kodas, ZIP + 4 skaiciai, telefono numeris
ir specialus numeris. Pirmasis raso penkis skaicCius. Jei paraSysite 1, tai gausite 00001.
Antruoju atveju i§ vieneto bus 00000-0001. Telefono numeris nelabai atitinka Lietuvos
standarta, todél geriau naudoti Custom, jis raSomas tokiu formatu 123-45-6789, o specialus,
tai Cia biity uZmiescio arba mobilus, Lietuvai taip pat nelabai tinka, jo formatas toks (12) 345-

67-8999.
. Custom - §is atributas leidzia susikurti savo lastelés Sablona.
2. Antroji kortel¢ pavadinimu Alignment. Joje galima nurodyti, kaip tekstas bus

lygiuojamas horizontalumo atzvilgiu Horizontal:, vertikalumo Vertical:. Taip pat lastel¢je galima
pasukti teksta kokiu nors kampu (Orentation). Yra ir trys punktai, prie kuriy galima uzdéti varneles:

a. Wrap text - jei tekstas netilps lasteléje, jis bus keliama { kita eilutg.

b. Shrink to fit - jei tekstas netilps lasteléje, jis bus suspaudziamas tiek, kad tilpty 1
lastele.

c. Merge celles - tik tik jei pazyméta lasteliy blokas, tokiu atvejy i§ bloko yra

padaroma viena lastelé.



3. Trecioji kortelé Font. Na apie ja tikriausiai nieko daug kalbéti nereikia, nors ir néra
daug ka pasakyti. Cia galima pasirinkti Srifta, stiliy, dydi, galima teksta pabraukti, nubraukti, parasyti
indekse ir t.t.

4. Ketvirtoji kortele¢ Border. Ji yra skirta lasteléms uzdéti rémelius, kurie bus
spausdinami (tos linijos, kurias jus matéte iki Siol, jos néra spausdinamos(Gridlines)).

5. Penktoji kortelé Patterns. Cia galima pasirinkti lastelés fono spalva ir uzdéti koki nors
Stricha, taip pat galima pasirinkti ir Stricho spalva. Lauke Sample, po kiekvieno veiksmo jiis matysite
pavyzdji, kaip atrodys jusy lastelé arba blokas.

6. Na paskutinioji kortelé Protection. Ten galima ant dviejy punkty uzdéti arba nuimti
varneles. Locked, reiskia, kad §i lastel¢ yra rakinama. Pagal nutyl¢jima, visos lastelés yra rakinamos.
Bet sakykime, kad jus darote, kokia dinaming lentelg, { kuria kiti zmonés ves tam tikrus duomenis, ir
jie bus, sakykime sumuojami. Tokiu atveju tas lasteles, i kurias bus vedami duomenys padarykite ne
Locked, o kuriuose bus formulés, palikite Locked. Paskui meniu eilutéje Tools-> Protection->
Protect sheet... galima uzrakinti puslapi, iSskyrus tas lasteles, nuo kuriy nuimtas atributas Locked.

Darbas su lastelémis ir blokais

Kaip pasteb¢jote atsidarius MS Excel programa, lastelé Al biina ryskiau apibraukta. Tai reiSkia, kad ji
yra pazyméta. Pazymeéti kita lastelg labai paprasta, tiesiog uzvedate ant jos pelés Zymekli ir paspaudziate kairj
pelés mygtuka, arba su klaviatiiros rodyklémis aukStyn, zemyn, i kair¢ ir 1 deSin¢ nueinate iki norimos
lastelés. Ta lastelé arba blokas kuris yra apvestas ryskiau yra pazymétas (toliau vadinsime aktyvus). Aktyvia
lastele galima kopijuoti perkelti, formatuoti ir t.t. Viskas kas bus daroma, bus priskiriama biitent aktyviai
lastelei arba ju blokui.

Jei jus uzvesite pelés zymekli ant aktyvios lastelés, paspausite kairj pelés mygtuka ir vesite pelg
norima kryptimi, tada Zymésis lasteliy blokas. DaZnai reikia, kad norima pazyméti bloka sudaro didelis
stulpelis, ilga eiluté ar net visas Excel lapas. Tokiu atveju su pele vesti yra labai nepatogu ir tai uzima daug
laiko. Tada reikia daryti Sitaip:

a. Norint pazyméti stulpelj reikia tiesio paspausti kairj pelés mygtuka ant vir$ stulpelio
esancios raidés (A..IV). Norint pazymeti kelis Salia esancius stulpelius - paspaudus laikyti ir vesti pelg
norima kryptimi. (Zitréti pvz. nr.1)

b. Norint pazyméti eilutg - viskas taip pat, tik pele reikia uzvesti ant Salia esanciy skaiciy.
(Zitréti pvz. nr.1)

c. Norint pazyméti visa lapa reikia paspausti kairi pelés mygtuka uzvedus ant laukelio,
kur susikerta stulpeliy ir eilu¢iy numeracija arba paspausti Ctrl+A. (Zitréti pvz. nr.1)

Kartais buna taip, kad reikia paZyméti 2 ar daugiau lasteliy blokus, kurie yra ne $alia vienas kito.
Tada, pazymime viena bloka, laikydami paspaudg Ctrl klavisa zymime antra bloka ir t.t., kiek tik jums reikia.
Kai tenka, kad biity dvi ar daugiau vienody lasteliy (ar bloky) jas galima kopijuoti. Paprasciausiai taip,
pazymime norima kopijuoti lastele(bloka), Edit-> Copy. Aplink ta lastelg (bloka) atsiras bégantis punktyrinis
apvadas. PaZymite ta lastelg, { kuria kopijuosite ir Edit-> Paste. Jei buvo aktyvus blokas, tada pazyméti (1 kur
kopijuoti) reikia tik kairigja virSuting lastelg. Jei lastel¢je buvo ne pastovi, o kintama reikSme, (buvo jraSyta
kokia nors formulé), tada ji pasislinko ir gavosi tikriausiai ne tai ko jus norite. MS Excel'is turi galimybg ir
pakelti lastelg (bloka) i§ vienos vietos i kita. Pazymime lastele (bloka), Edit-> Cut. Aplink ta lastele (bloka)
atsiras bégantis punktyrinis apvadas. PaZymite ta lastele i kurig perkelsite ir Edit-> Paste.

Specialus lasteliy (bloky) kopijavimas.



Atsitinka kartais taip, kad jis, sakykime, pasidaréte lentelg, i ja suraséte reikSmes ir tada jums prireiké
dar vienos tokios lentelés $alia, kur jau reikés rasyti kitas reik§mes. Zinoma jiis galite nukopijuoti tokia pat ir
perraSyti reikSmes. Bet kam tai daryti, kai MS Excel'is komanda Paste special. Ten yra saraSas punkty ir
langas suskirstytas i dalis: Paste, Operation ir yra trys papildomos komandos.

a. All - viska, taip kaip yra, nepakeicia stulpelio plocio ar eilutés aukscio.

b. Formulas - kopijuoja tik formulg.

c. Values - kopijuoja tik reikSmes. Jei buvo kintamieji, tai pasidarys pastovi reikSmé.

d. Formats - kopijuoja formata: rémelius, fontus, spalva ir t.t., tik taip pat nekopijuoja
dydzio

e. Comments - kopijuoja komentara.

f. Validation - kopijuoja tik lastelés duomeny patvirtinima.

All axcept borders - kopijuoja viska iSskyrus rémelius.

h. Column widths - kopijuoja tik stulpelio ploti.

1. None - tai reiskia, kad nereikia jokios operacijos.

J- Subtract - kopijuojama reikSme atima iS lasteléje esancios reikSmés.
k. Multiply - padaugina i$ lasteléje esancios reikSmés.

1. Divide - lasteléje esancia reikSme padalina 1§ kopijuojamos reikSmés.
m. Transpose - kopijoje lentele gaunasi pasukta 90 laipsniy kampu.

n. Paste link - padoro nuoruoda i kopijajamas lasteles. Pvz.: jei kopijuojate lastele Al 1
BS5, tai BS Iastelé bus "=A1" (rodys Al lastelés reikSmg), jei pakeisite Al pasikeis ir BS.

Eiluciy, stulpeliy, lastely ir lapy iSmetimas.
Norédami paSalinti viena lastele, paZymite norima pasalinti lastele ir einate Edit-> Delete.
Atsidariusiame dialogo lange galima pasirinkti:

o Shift cells left - tai reiskia bus Salinama lastelé (arba blokas), o i ta vieta pasislinks
lastelés 1§ deSinés puses.

o Shift cells up - tai reiSkia bus Salinama lastel¢ (arba blokas), o i ta vieta pasislinks
lastelés, kurios yra Zemiau Salinamy.

o Entire row - i8sitrins visa eiluté, kurioje yra pazymétoji lastelée. Jei bus pazymétas
blokas per kelias eilutes, tada iSsitrins kelios eilutés.

o Entire column - i$sitrins visas stulpelis.

Taip yra iStrinamos eilutés ir stulpeliai ir { ju vieta atsistoja kitos reikSmes, priklausomai nuo to kaip
jus pasirenkate. Lapy trynimas vyksta labai paprastai. Einate Edit-> Delete Sheet. Jei atsidariusioje lentel¢je
paspausite "OK" aktyvus puslapis bus iStrintas. Jei norite trinti iSkart kelis puslapius, paspaud¢ CTRL
mygtuka pazymekite visus norimus ir vykdykite ta pacia komanda. Démesio!!! jvykdzius $ia komanda,
veiksmo grazinti atgal nebegalima, komana Undo neveikia.

Reik$miy ir formaty trynimas.



Yra kita komanda - Clear, kuri trina tik lasteléje esanéia reik§me, formata, komentara. Si komanda
randasi Edit-> Clear. Saktyvinus Clear:

o All - yra trinami formatai ir esanti reikSme arba tekstas.

o Formats - tik formatai, reikSmés, tekstas pasilieka, tik Iastelé pasidaro Default stiliumi.
o Contents Del - trinama tik reikSme arba tekstas.

o Comments - trinamas tik komentaras.

Eiludiy, stulpeliy, lasteliy ir lapy jterpimas.

Sios komandos, savo atlikimu, labai panasios | trynima. Pradékime taip pat nuo lastelés jterpimo.
Pazymite kurioje vietoji turi atsirasti jterpta lastel¢ (arba blokas) ir einate Insert-> Cells... Atsidaro Inset
dialogo langas. Jame galima pasirinkti:

o Shift cells right - tai reiSkia, kad lastelé esanti toje vietoje ir visos | deSing nuo jos bus
patraukiamos i deSing pusg.

o Shift cells down - tai reiskia, kad lastelé esanti toje vietoje ir visos | apacia nuo jos bus
patraukiamos i apacia.

o Entire row - tai reiskia, kad bus iterpiama eiluté, o buvusi patraukiama zZemyn. Eilutg
taip pat galima iterpti ir Insert-> Rows.

o Entire column - tai reiskia, kad bus jterpiamas stulpelis, o buves bus patraukiamas 1
desing pusg. stulpeli taip pat galima iterpti ir /nsert-> Columns.

Pastaba: jei prie jterpdami lastele pazymesite lasteliy bloka, tada ir bus iterpimas tokio dydzio lasteliy
blokas. Jei pazymetas blokas bus, sakykime per tris eilutes ir du stulpelius, tada: atlikus Insert-> Rows -
isiterps trys eilutés, o Insert-> Columns - du stulpeliai.

Naujo lapo jterpimui naudojama komanda Insert-> Workssheet, ji iterpia standartini MS Excel lapa.
Jei uzlipsite ant esamo lapo ir paspausite deSini pelés mygtuka, atsidariusiame meniu, pasirinkus /nsert..
atsidarys Browse tipo "Insert.." langas, kuriame bus galima pasirinkti norima Sablona, na bet apie Sablonus
veliau.

Spausdinimas su MS Excel programa.
Visi spausdintuvo nustatymai Ms Excel yra Page Setup dialogo langekuri galima ikvieti: File-
>Page Setup. Siame lange yra keturiuos dialogo kortelés:

1. Page cia galite pasirinkti lapo orientacija: Portrait - vertikalus, Landscape -
horizontalus lapas. Taip pat spausdinimo skalg, kiek procenty tikro dydzio spausdinti arba nurodyti i
kiek lapy sutalpinti esant tokiam plocio ir auk$cio santykiui. Dar galima pasirinkti lapo formata,
spausdinimo kokybe ir pirmojo lapo numeri (First page number:).

2. Margins - viskas apie lapo parasStes. Galite nurodyti ju dydzius, taip pat galite
pasirinkti, kad lape esantis turinys biity centruojamas vertikalumo ir/arba horizontalumo atzvilgiu.

3. Header/Footer - infromacija, kuri bus rodoma virSutinéje Header ir/arba apatinéje
parastéje. Galite pasirinkti 1§ MS Excel siiilomy arba pasidaryti patys, paspaud¢ mygtuka Custom
Header ir/arba Custom Footer. Ten galésite keisti parastés Sriftus, ivesti data, puslapiy skaic¢iavima
laika, Sheet(puslapio) varda, laika ir kita informacija.



4. Sheet Cia jus galite pasirinkti, koki plota spausdinti: Print area:. Taip pat galite
nurodyti eilutes ir stulpelius, kuriuos kartoti kiekvieno lapo virSuje ir kair¢je lapo pus¢je: Rows fo
repeat at top: ir Columns to repeat at left. Dar galite pasirinkti kas bus spausdinama: Grindlines - bus
spausdinamos linijos, kurios skiria lasteles. Black and white - viskas spausdinama tik juoda ir balta
spalvomis. Draft quality - brézinio kokybé. Row and column heading - bus spausdinamos raidés
esancios stulpeliy virSuje ir skaiciai Iasteliy kairéje. Taip spausdindami lastelés koordinates galésite
suzinoti ir ant atspausdinto lapo. Jos yra kartojamos kiekviename lape. Comments - komentarai. Cia
dar galima pasirinkti ar spausdinti toje vietoje, kur yra komentaras As displaet on sheet, ar lapo
apacioje atspausdinti lastelés koordinate, kurioje yra komentaras ir tada komentaro turini A¢ end of
sheet. Na ir paskutinis parametras, kuri galite pasirinkti tai kokiu eiliSkumu sudélioti lapus.

——— Pirma eina i apacia, kai pasibaigia zidiri ar deSin¢je puséje. Down, then over
EE |E g EE Pirma | deSing pus¢, po to Zemyn. Over, then  down
EE 8jE 38

EEEE AL

EE- Tt 8

Komentaro Comment jterpimas.

Komentarai yra naudojami, tada, kada apie reikiama lastele yra reikalinga kokia nors papildoma
informacija, kuri neturi buti tos lastelés reikSme. Pvz.: Excel lentelés virSuje(lasteléje d1) galime padyri
lastele su formul¢ =sum(a2:a65356) ir lastel¢je "d1" iterpti komentara: "Pirmojo stulpelio suma". Tokiu
atveju uzvedus pelés kursoriy atsiras uzrasas: "Pirmojo stulpelio suma" ir net ne bylos autoriui bus aisku i§
kur gauta "d1" lastelés reikSmé. Norint jterpti komentara, visy pirma reikia pazyméti lastele, kurioje norite
iterpti komentara, tada: Insert-> Comment. Salia lastelés atsiras Text Box su rodykle i jiisu pazyméta lastele.
Text Box lauke ir rasykite komentara. Komentaro teksta taip pat galima formatuoti visais fiziniai formatais,
t.y. pabraukti, paryskinti, pakeisti spalva, Srifta ir t.t. Pati komentaro fona taip pat galima formatuoti ivairiais
fiziniais formatais. Kad gauti komentaro formatavimo dialogo langa, reikia daryti Sitaip: Insert-> Edit
Comment, tada su palés kursoriumi paspausti ant vienos i§ kampiniy rankeny ir Format-> Comment. Tada
atsidaro "Format Comment" dialogo langas.

Svarbu. Pagal nutylé¢jima, MS Excel'io opcijose default reikSmé yra uzdéta Comment indicator only,
tai reiSkia, kad i lastele iterpus komentara, lastelés deSiniajame virSutiniame kampe atsiras raudonas
trikampio formos indikatorius. Jei Tools-> Options-> View pakeisime Comment & indicator, tada matysime
ir indikatoriy ir komentara (net neuzvedus pelés kursoriaus ant lastelés). Jei pasirinksime Nomne, tada
nesimatys nei indikatoriaus, nei komentaro, tokiu atveju pasizitréti galima tik pakeitus parametrus arba
paspaudus View-> Comment.

Kintamas lastelés formatas.

MS Excel'is turi galimybg uzdéti lastelei ir kintama formata priklausomai nuo lastelés reikSmés.
Geriausiai visa tai galima iliustruoti pavyzdziu. Sakykime, kad mes visa savaitg stebime kokio nors objekto
temperatiira, kuri svyruoja nuo -10 iki +10. Stebéjimas vyksta nuo pirmadienio iki sekmadienio. Pasidarome
tokia lentele:

A B
1 |Pirmadienis -9
2 |Antradienis -7
3 |Treciadienis +1
4 |Ketvirtadienis -2
5 |Penktadienis +8




6 |Sestadienis 0
7 Sekmadienis +1
8 |Vidurkis -1,14286"

"Kad gautume vidurki 1 lastelg "b8" {vedame formule =average(bl:b7). Dabar mes kiekviena diena
iraSome kokia buvo temperatira. Mums reikia, kad lastelés, kurios temperatira yra minusiné, fonas
nusidazyty melynai, o pliusinés - raudonai. Lygiai taip pat ir su vidurkio Iastele. Pazymime Iasteliy bloka
(b1:b8) ir einame Format-> Conditional Formatting... Atsidariusiame dialogo lange jiis matysite Condition
1, ten bus pasirinkimo galimybés. Pirmame palikite Cell Value Is, antrame lauke galima pasirinkti salyga (ju
reik§més iSvardintos Zzemiau), pasirinkite greater than (daugiau uz) tre¢iame lauke jrasykite reikSme, Siuo
atveju "0". Tada spaudziate mygtuka Format... ir nustatote norima formata, jei Condition I salyga yra
teisinga. Siuo atveju mes pasirenkame raudona fono spalva. Paskui spaudziame mygtuka Add>>. Ir
nustatome antraja salyga. Cia salyga pasirenkame less than (maZziau uZ) ir formate pasirenkame mélyna
spalva. Spaudziame "OK".

between In’c_ervaltav, Cia rei_ki? ir_aéyti dvi _riaikép“!es, pirmoji (nuo), antroji
(iki). Irasytos reiksmés nepaklitina j intervala.

not between ISskyrus nurodytg intervala.

equal to Lygu, atitinka "="

not equal to Nelygu

greater than Daugiau uz, atitinka ">"

lees than Maziau uz, atitinka "<"

greater than or equal to Daugiau arba lygu uz, atitinka ">="

less than or equal to Maziau arba lygu uz, atitinka "<="

IS viso galima sura$yti tris salygas, t.y. gali biiti trys Condition lentelés. Condition 1, Condition 2 ir
Condition 3. Taigi vienai lastelei galima pritaikyti iSkarto keturis formatus, priklausomai nuo jos reikSmes.
Keturis todél, kad vienas formatas yra Default, jis pasilieka jei yra netenkinamas nei vienas Condition. Miisy
pavyzdyje apie temperatiiras toks atvejis yra, kai temperatira yra "0", nes "0" nei didesnis uz save nei
mazesnis. Zinoma, mes galéjome "0" priskirti kokiai nors grupei arba didesnei arba maZesnei. Jei maZesnei -
Condition 2 salyga reikéjo pasirinkti less than or equal to , jei didesnei - Condition 1 - greater than or equal
to.

Skaiciavimas lastelése ir funkcijy naudojimas.

Kiekviena MS Excel lastelé, gali skaiiuoti. Joje galima atlikti paprastus veiksmus ir raSyti sudétingas
funkcijas. Kad priversti lastelg skaiCiuoti jos pradzioje reikia parasyti zenkla "=" ir toliau rasyti norima
veiksma arba funkcija. Pvz.: 1 lastele iveskite toki turini: "=15+45", paspaud¢ Enter matysite "60". Pazymeje
lastele Formula bar- (jei nesimato Formula bar eilutés, eikite Tools-> Options ir srityje Show prie Formula
bar uzdékite varnelg.) eilutéje matysite tai ka jiis ir iraSéte. Tai reiSkia, kad lastelés, kurios pradzioje yra
lygybés zenklas vartotojui rodo ne jvesta turini, o reikSme.

Dabar, pabandykite jvesti ne veiksmy eilutg, o funkcija i§ MS Excel funkcijy saraso. Kad pamatytume
skirtuma, pradziai panaudokime funkcija SUM(). Parasykime taip: "=SUM(15;45)" paspaude Enter lastelés
reikSme¢ gausime "60", lygiai taip pat, kaip ir pirmuoju atveju. Bendra funkcijos SUM forma yra tokia
SUM(Numberl; Number2; ...;Number30). Apskritai MS Excel'yje visos funkcijos yra rasomos tokia
forma:



FUNKCIJA(pirmas_kintamasis_arba_konstanta;
antras_k a konstanta;...;paskutinysis k a konstanta)

Tarp kiekvieno kintamojo (konstantos) yra dedamas ; (kabliataSkis). Lasteléje A1 paraSykite 15, B1 - 45, C1
- =SUM(A1;B1). Tokiu atveju jau gausis dinamin¢ lentelé, nes kei¢iant Al ir B1 reikSmes, automatiskai
keisis ir C1 reikSmeé.Kartai tarp kintamyjy ir konstanty yra dedamas ir dvitaskis (:), tokiu atveju yra
nurodomas blokas. Pvz.: yra sarasas skai¢iy lastelése nuo Al iki AS, galima raSyti: =SUM(A1;AS) ir
=SUM(A1:A5). Pirmuoju atveju gausime Al+AS, antruoju AI1+A2+A3+A4+AS. Taip pat galima ir kaip
funkcijos kintamaji (arba konstanta) rasyti ir kita funkcija. Pvz.: Surasykime bet kokius skaicius stulpelyje
nuo Al iki A4 ir ta pati padarykite nuo B1 iki B4(skaicius rasykite skirtingus). Lasteléje C1 paraSykite tokia
funkcija: =SUM(MIN(A1:A4);MAX(B1:B4)). Tada lasteléje C1 vienas jus matysite maziausios A stulpelio
ir didZiausios B stulpelio reikSmiy suma.

Funkcijy paaiskinimai.

Funkcijas galima i$sikviesti komanda, Insert-> Function. Jos yra suskirstytos i devynias kategorijas,
kurias matysite kairiajame Paste Function dialogo lango, lange. Pasirinkus kategorija A//, lange Function
Name: matysite visas funkcijas, o pasirinkus kategorija Most Recently Used - matysite paskutines deSimt jusu
naudoty funkcijy. Skyrelyje "Skai¢iavimas lastelése ir funkcijy naudojimas" yra apraSyta funkcijy bendra
sintaksé: FUNKCIJA(kintamas1; kintamasis2; ....). Apie tai kokius kintamuosius, kokiai funkcijai reikia
raSyti ir koki rezultata gausime ir bus Sis skyrelis. Kadangi tokius duomenis lengviausia pateikti lenteléje, tai
a$ juos pateiksiu lenteléje, kurioje pirmame stulpelyje bus funkcijos vardas (Function Name), antrame
reikalingi kintamieji - ir jy paaiskinimai, treCiame - platesnis paaiSkinimas arba(ir) pavyzdys.

Date & Time, data ir laikas.

DAY() serial number - datos Parodo tik ménesio dieng nuo 1 iki 31. Pvz.: "A1" -
numeris. MS Excel data yra "2000.12.22", tada =DAY (A1) gausime 22
skai¢iuojama nuo 1900m.
sausio 1d. Sios dienos
serial_number=1

Math & Trig, matematika ir trigonometrija.

ABS() number - skaicius Parodo realy skaiciy. Pvz.: ABS(-2) gausime 2.

FACT() number - skaicius Pvz.: FACT(5) gausime 1*¥2*3%4%*5 =120

INT() number - skaiCius ISskiria svaikaja skaiciaus dali. Pvz.: INT(1,987)

gausime 1.

PI() -— Skaicius Pi = 3.14159265358979

POWER() number - skaicius, power - Kélimas laipsniu. Atitinka operatoriy (*). Pvz.:
laipsnis. POWER(12;5) gausime 248832

PRODUCT() numberl... - skai¢ius galima  |Skaiciy sandauga. Pvz.: PRODUCT(2;3;4) gausime
iki 30. 24,

RAND() - Atsitiktinai sugeneruoja skaiciy 0,7??????. Jei norite,

kad jums lasteléje atsitiktinai sugeneruotu skai¢iy nuo
0 iki 100 darykite taip: INT(RAND()*100). Kiekvienu
bet kokios lastelés pakeitimu bus generuojmas nuajas
skaicius.

ROMAN() number - skaicius, bet ne Pavercia parasta skai¢iy | roménisSkus raSmenis.
didesnis uz 3999. form - forma,




gali buti 0,1,2,3.4, true, false.
Kuo skiriasi pabandykite patys,
gal jiis geriau nusimanote apie
roméniskus skaicius.

ROUND() number - skaicius. num_digits |/Apvalina skaiciy iki nurodyto tikslumo. Pagal
- kiek skaiciy po kablelio 1 -  |matematines taisykles. ROUND(1,5; 0) gausime 2. Jei
vienas skaicius po kablelio. num_digits - 0, tada iki sveiko skaiCiaus.

ROUNDDOWN() |number - skaiCius Apvaling skaiCiy, iki nurodyto tikslumo imdamas

ROUNDUP() num_digits - kiek skai¢iy po  |Zemesnj/aukstesni skaiciy. ROUNDDOWN(7.9; 0)
kablelio. gausime 7. ROUNDUP(7,1; 0) gausime 8.

SQRT() number - skaicius. Kvadratiné Saknis. SQRT(16) gausime 4. SQRT(-16)

gausime #NUM!, reikia daryti taip SQRT(ABS(-16))
gausime 4.

SUBTOTAL)() function_num - funkcijos Atliekamas veiksmas su lasteliy reikSmémis,
vardas, skaiCius nuo 1 iki 11, |priklausomai nuo function num parametro. Pvz.:
placiau Cia. lasteleje "A1" - 15, "A2" - 14 SUBTOTAL(9;A1;A2)
refl..ref29 - Iasteliy blokas. gausime 29. 9 - reiSkia SUM, Al - refl, A2 - ref2.
Galima nurodyti 29.

SUM() numberl...number30 - Sumuoja nurodytus skaicius. Pvz.: SUM(15;13)
skaiCius gausime 28.

SUMIF() range - lasteliy blokas, Sumuoja tik tas reikSmes, kurios atitinka nurodyta
criteria - kriterijus, kriteriju. Pvz.: Lasteliy bloke, "A1:A5" surasykime
sum_range - sumuojamas skaicius nuo 1 iki 5. Tada
blokas. SUMIF(A1:A5;">2";A1:AS5) gausime 12 (3+4+5).

Kad biity aiskiau pabandykime range ir sum_range
nurodyti skirtingus blokus. Analogiskai bloke "B1:B5"
suraSykite bet kokias reikSmes. Tada
SUMIF(A1:A5;">2";B1:B5), tokiu atveju bus i§ B
stulpelio sudedomos tos reik§mes, prie kuriy A
stulpelyje reikSmé yra didesné uz 2.
SUMPRODUCT() |arrayl..array30 - blokas. Veiksmai atliekami tokia tvarka. arrayl(pirma
reikSmé)*array2(pirma reikSme) + arrayl(antra
reik§meé)*array2(antra reikSmé) ir t.t.

SUMSQ() numberl...number30 - Sumuoja, pries tai kiekviena démenj pakeldamas
skaiciai. kvadratu. Pvz.: SUMSQ(3;9) gausime 3°+9°=90.

SUMX2MY2() array_x - x reikSmes, Atitinka tokia formule: sum(x*-y?). Pvz.: array x=
array_y -y reikSmés. {4,5}. array_y={2,4}. Excelis atliks tokius veiksmus:

(42-22)+(5%-4)
(16-4)+(25-16)
12+9=21.
SUMX2PY2() array_x - x reikSmes, Atitinka tokia formule: sum(x*+y?). Pvz.: array_x=

array_y -y reikSmés.

{4,5}. array_y={2,4}. Excelis atliks tokius veiksmus:
(42+22)+(52+42)

(16+4)+(25+16)

20+41=61.

SUMXMY2()

array_x - x reikSmés,

Atitinka tokia formule: sum(x-y)>. Pvz.: array x=




array_y -y reikSmes.

{4,5}. array_y={2,4}. Excelis atliks tokius veiksmus:
(4-2)*+(5-4)°

Q) +(1)°

4+1=5.

Text, tekstinés funkcijos.

CHAR() number - skaicius. ANSI koda pavercia i simboli. Lasteléje Al irasykite
skaiciy nuo 1 iki 255, pasirinkime 65, o pvz.: Lastel¢je
A2 =CHAR(A1), A2 gausime raidg "A".

CLEAN() text - tekstas. IS teksto iSmeta nespausdinamus simbolius.
Dazniausiai naudojama kartu su kitomis funkcijomis.
Pvz.: =CLEAN(CHAR(7)&"TEKSTAS"), taip uzrase
gausime TEKSTAS. (Apie simbolio & naudojima
skaitykite ?777??

CODE() text - tekstas. Simboli pavercia 1 ANSI koda. Jei fext nurodysite zodj,
tai pavers pirma raid¢. Pvz.: =CODE("A"), gausime
65, =CODE("Arabija"), gausime 65.

CONCATENATE)() textl, text2, .... text30 - tekstas |Sujungia kelis tekstus i viena. Pvz.: "A1" - Labas,
"A2" - vakaras, 0 "A3" =CONCATENATE(A1;A2),
gausime Labas vakaras.

DOLLAR() number - skaicius. Skaiting reikSme pavercia i pinigus. Jei jisy
decimals - kiek skaiciy po kompiuterio settingai yra lietuviski, tai pavers { litus.
kablelio rodyti. Pridedamas "Lt" Zenklas. Pvz.: "A1" - 101,48, "B1" -

=DOLLAR(A1;2), gausime 101,48 Lt.

EXACT() textl, text2 - tekstas. Sulygina dvi eilutes teksty. Atsizvelgiama ir

dydziasias ar mazasias raides. Pateikia atsakymus
TRUE - teisingai arba FALSE - neteisingai.

FIND() find_text - tekstas kurio reikia |IeSko nurodyto vieno simbolio, nurodytoje simboliy
ieskoti. eilutéje ir atsakyma duoda kelintas tas simbolis yra. jei
within_text - tekstas kuriame |simbolis kartojasi kelis kartus, atsakymas pirmesnis i$
reikia ieskoti. kairés pusés. Pvz.:FIND("m";"Mano mamai") gausime
start_ num - nuo kelinto 6. FIND("m";"Mano mamai";7) gausime 8. Diziosios
simbolio pradéti (nebiitinas, jei |ir mazosios raidés turi skirtuma.
nieko tai nuo pirmo).

FIXED() number - skaicius. Skaitine reikSmg pavercia i teksting.
decimals - kiek skaiciy uz
kablelio paimti.
no_commas - nezinau, bet jis
néra biitinas.

LEFT() text - tekstas. num_chars - Paima is tekstinés lasteles nurodyta kieki simboliy.

RIGHT() kiek simboliy, tarpai taip pat  |LEFT - i§ kairés, RIGHT - i§ deSinés. Pvz.:
skaiciuojami. =LEFT("Donatas";2) gauname "Do".

=RIGHT("Donatas";2) gauname "as".

LEN() text - tekstas. Suskaiciuoja kiek simboliy sudaro eiluté. Kazkodél

rasomas, kad reikalinga tekstiné reikSme, bet puikiai
veikia ir su skaitinémis eilutémis. Pvz.:
=LEN("Donatas") gauname 7. Tarpai taip pat




skaiciuojami.

LOWER() text - tekstas. Pavercia teksta LOWER - maZosiomis raidémis,

UPPER() UPPER didZiosiomis. Pvz.: =LOWER("DONATAS")
gauname "donatas", =UPPER("donatas") gauname
"DONATAS"

MID() text tekstas, Paima i$ simboliy eiluté norimo ilgio iSkarpa. Pvz.:
start_ num - pradinis simbolis, |=MID("DONATAS";2;4) gausime "ONAT".
num_chars - simboliy skaicius.

PROPER() text tekstas. Kiekvieno teksto zodzio pirmaja raide padaro didziaja.

Pvz.: =PROPER("DoNataS bRIKAS") gausime
"Donatas Brikas"

REPLACE() old_text - senas tekstas. Gali pakeisti vieno teksto dalj ar visa teksta naujo
start_ num - pradZios tekstu. Pvz.: =REPLACE("Labas";3;1;"Rytas")
simbolis(skaicius) gausime "LaRytasas". "Labas" - old text, 3 -
num_chars - simboliy skaicius. |start num, nurodo, kad reikia keisti pradedant treciu
new_text - naujas tekstas. simboliu, 1 - num_chars, parodo, kad keisti tik viena

simbolj, "Rytas" - new_text, naujas tekstas, kuriuo
reikia pakeisti, $iuo atveju zodzio Labas, trecia raidg.

REPT() text - tekstas, Kartoja teksta nurodyta kieki karty. Galima kartoti ir
number_times - kiek skaicius, bet jie bus suprantami kaip tekstas. Pvz.:
karty(skaicius) =REPT("Donatas";2) gausime "DonatasDonatas".

SEARCH() find_text -ieSkomas tekstas,  |Atsakyma iSveda kelintu simboliu prasideda ieSkomas
within_text - tekstas kuriame  [tekstas. Pvz.: =SEARCH("Rytas";"Atéjo rytas")
ieskoti, gausime 7, didziosios ir mazosios raidés neturi
start_ num - nuo kelinto skirtumo.
simbolio pradéti (nebiitinas).

SUBSTITUTE()  text - tekstas, Skirta tekstinéje eilutéje surasti nurodyta simbolj ar ju
old_text - tekstas kuri reikia  |seka ir pakeisti kitu, nurodytu. Pvz.:
pakeisti, =SUBSTITUTE("Pirmadienis, 1991m.";"9";"8")
new_text - tekstas kuriuo reikia|gausime "Pirmadienis, 1891m.", o
pakeisti, =SUBSTITUTE("Pirmadienis, 1991m.";"9";"8";2)
instance num - skaicius gausime "Pirmadienis, 1989m.".
parodantis nuo kelinta jungini
pakeisti (nebiitinas, pagal
nutyléjima 1).

T() value - reikSme. Tikrina ar lasteléje yra reikSmée ar tekstas. Jei tekstas,
tai lastelé lygi nurodytos lastelés reikSmei, jei skaicius
ar kintama reikSme, lastelé pasilieka tuscia. Pvz.: "A1"
lastelé - "Labas", "A2" - 150, "A3" - True, "A4" -
"True". Tada =T(Al) gausime "Labas", =T(A2)
gausime """, =T(A3) gausime """, =T(A4) gausime
"True".

TEXT() value - reikSme, Pavercia lastelés reikSme i teksta nurodytu formatu.

format_text - teksto formatas
(pvz.: 0,00Lt).

Pvz.: "A1" lastelé - 52, =TEXT(A1;"0,00Lt") gausime
"52,00Lt", bet i reikSmé bus tekstas ir su ja negalés
atlikti jokiy matematiniy veiksmy.




TRIM() text - tekstas. IS teksto eilutés ismeta nereikalingus tarpus. Labai
pravercia naudojant su funkcijomis LEFT, RIGHT.
Pvz.: =TRIM(" Einu namo ") gausime "Einu namo".
VALUE() text - tekstas. Teksto eilute, kurig sudaro skaiciai, pavercia reikSme.
Jei teksto eilutéje yra simboliy nesivercianciy i
skaicius gausite klaida #VALUE!. Pvz.:
=VALUE("0,05Lt") gausime 0,05.
Logical, loginés funkcijos.

AND() logicall, logical2... - loginés  |ReiSkia "ir". Duoda atsakyma FALSE/TRUE. Jei visos
salygos, gali buti iki uzduotos salygos teisingos, tada bus TRUE, jei bent
trisdeSimties. viena salyga netenkinama arba neteisinga - FALSE.

Pvz.: =AND(2>1;3<10) gausime TRUE,
=AND(2>1;3>10) gausime FALSE.

FALSE() Néra Duoda reik§me FALSE arba TRUE. Naudojama kartu

TRUE() su kitomis funkcijomis, kad reikalinga FALSE/TRUE

reikSmes. Pvz.: =FALSE() gausime FALSE.

IF() logical test - loginis testas, Uzdavus loging salyga, pagal jos sprendima lasteléje,
value _if true - reikSme jei gali biiti viena {8 reikmiy. Pvz.: "A1" - 15, "A2" - 17,
loginis testas teisingas, tada: =IF(A1<A2;A2-A1;A1-A2) gausime 2. Jei "A1"
value _if false - reikSme jei ir "A2" reikSmes sukeistume vietomis, vistiek
loginis testas neteisingas. atsakymas bus du, nes tada loginé salyga bus FALSE

ir bus atliekamas atvirkstinis veiksmas.
NOT() logical - loginé salyga. Duoda reikSm¢ TRUE/FALSE. Reiskia neigima.
Paimkime IF pavyzdyti ir papildykime funkcija
NOTY(), ir dar Siek tiek pakeiskime reikSmes:
value_if false ir value if true.
=[F(NOT(A1<A2);"Salyga tenkinama";"Salyga
netenkinama") gausime "Salyga netenkinama", nors
"A1" yra maziau uz "A2".

OR() logicall, logical2 - loginés Labai panasi 1 funkcija AND(), tik OR() reiskia arba.

salygos, gali biiti iki
trisdeSimties.

Duoda reikSmes TRUE/FALSE. TRUE yra tada, kada
nors viena salyga yra tenkinama. Pvz.:
=0R(2>1;3<10) gausime TRUE, =OR(2>1;3>10)
gausime TRUE.

Formuliy kopijavimas.

IS pirmo zvilgsnio gali pasirodyti, kad jei padarau lentelg, kurioje viename stulpelyje turi bati kity
stulpeliy suma, tai reikés kiekvienoje eilutéje raSyti =SUM(A1;B1) antroje =SUM(A2;B2) ir t.t., o jei ty
eiluc¢iy 100 ar net 1000. IS tikro ¢ia néra jokios bédos. Padarykite Sitaip: SuraSykite bet kokius skaicius
stulpelyje A nuo Al iki A10, paskui ta pati padarykite stulpelyje B, o stulpelyje C jums reikalinga kiekvienos
eilutés suma. Tada lasteléje C1 parasykite =SUM(A1;B1), pazymékite lastele C1. Tada Edit-> Copy arba
klavisai Ctrl+C. Paskui pazymékite lasteliy bloka C2:C10 ir Edit-> Paste arba klavisai Ctrl+V. Tokiu atveju
MS Excel'is pats supras, kad Zemiau jus norite sudéti sekanciy eilu¢iy duomenis ir lasteléje C2 bus
=SUM(A2;B2), o lastele C10 =SUM(A10;B10). Kartais reikia taip, kad kopijuojant lastelg su formulg i kita
vieta, formulés kintamieji nesikeisty o iSlikty pastovus. Tokiu atveju lastelé koordinates reikia atskirti
simboliais (§), pvz.: SUM($AS$1;$B$1). Tada nesvarbu kur jiis kopijuotuméte ta lastelg, joje visada bus Al ir
B1 lasteliy reikSmiy suma. Taip pat galima naudoti lasteliy vardus.




Funkcijy raSymas.
I lasteles raSyti ranka visas kity lasteliy koordinates, déti skliaustelius, kabliataSkius yra labai
nepatogu ir aplamai sunku nesusimaiSyti tarp tiek daug lasteliy ir jei raSome ilgas funkcijas skliausteliy.

Pirma, norédami i Iastelg ivesti funkcija, Zenkla

spauskite ne klaviattroje o Formula bar juostoje,
paveikslélyje mygtukas pazymétas violetine spalva. Tada raSykite funkcijos pavadinima ir padékite
pirmaji skliaustelj. Atsidarys langas, kur bus iSvardinti tos funkcijos kintamieji (arba konstantos). Prie
kiekvieno kintamojo eilutés gale bus mygtukas (paveikslélyje pazymétas geltonai), kuri paspaudus, jiis savo
byloje gali nurodyti lastelg arba bloka, kur yra tas kintamasis (arba konstanta), paskui paspaudus vél toki pat
mygtuka, grisite { ta pati langa. Taip nurodykite visus kintamuosius, jei kiti yra visada konkretus skaicius
galima raSyti ir ranka. Tada spauskite OK. Visi skliausteliai ir kabliataSkiai bus sudéti kaip priklauso ir jums
nereikés galvoti: "Kokioje dabar Iasteléje as jrasiau ta kintamaji

Lastelés vardo jterpimas.

Kartais vietoje lastelés koordinac¢iy galima naudoti Iastelés varda. Kad suteiktume kokiai nors Iastelei
varda darome taip: Insert-> Name-> Define..., atsidaro Define Name dialogo langas. Eilutéje Names in
workbook: raSome varda (jis negali buti su tarpais ir negali kartotis du tokie pat vardai tame paciame faile).
Eilutéje Refers to:, mes matome lastelés (arba bloko) koordinates, jei jos netinka, paspaudus mygtuka
desingje galima nurodyti kita lastelg arba bloka. ParaSius varda, spaudziame Add, po to OK. Tokiu atveju
funkcijose naudojant Sios lastelés reikSme kaip kintamaji nereikés raSyti jos koordinaciy, bet bus galima
raSyti varda. Pvz.: Al pavadinkime démuo_pirmas, o B2 - démuo_antras, tada C1 Iasteléje galime rasyti taip:
=SUM(démuo_pirmas;démuo_antras), ir tos lastelés reikSmé bus Al ir Bl reikSmiy suma, nepriklausomai
kur mes nukeltuméme ar nukopijuotuméme lastele C1.

n_n

Grafiky sudarymas su MS Excel'iu.
Visy pirma, prie§ pradedant daryt] bet koki grafika, reikia duomeny, pagal kuriuos turi butj jis
sudarytas. Duomenys suvesime MS Excel lentel¢je. Grafikui padaryti panaudosime Chart Wizard

Savaités diena Lankytojai
Pirmadienis 30
Antradienis 32
Treciadienis 28
Ketvirtadienis 34
Penktadienis 37
Sestadienis 70
Sekmadienis 62




tada pazymekite visa lentelg (kartu ir antrasting eilute) ir paspauskite mygtuka. Atsidarys, Chart
Wizard dialogo langas, kurj sudaro keturi zingsniai:

1. Pirmame zingsnyje jus turésite pasirinkti grafiko tipa. Standartineje MS Excel 2000 yra
14 tipy grafikai, i$ kuriy kiekvienas tipas dar turi nuo 2 iki 7 sub tipu. (sub-type). Dar galima rinktis ir
1§ Custom Types kortelés, bet turékite omenyje, kad ten yra standartinio tipo grafikai, tik su
Ivairiausiai pakeistomis spalvomis, legendos, serijos ir t.t. vietomis. Todél pasirinkus bet kurj i$
standartinio tipo bus galima padaryti analogiSkus, Cia jau viskas jusy fantazija. Taip pat savo sukurta
tipa galésite itraukti 1 Custom Types/User-defined sara$a. Musu pavyzdziui mes pasirinkime tipa
Column - stulpelinis grafikas ir ketvirta pagal eilg sub-tipa. Tai reiskia, kad misy stulpeliai bus su 3D
efektu. Na pirmas zingsnis atliktas. Spaudziame Next > .

2. Antrame Zingsnyje jiis jau i$vysite savo grafiko pavyzdi. Siame Zingsnelyje yra dvi
kortelés:

a. Data Range - tai duomeny koordinatés. RaSomos su operatoriumi "$" - tai
reiSkia, kad nepriklausomai nuo grafiko vietos juos visada iSliks fiksuotos. Pvz.:
=Sheet1!$A$1:$B$8. Antras kriterijus, kuri galima pasirinkti, tai kaip grafike bus déstomi
jusy lyginami dalykai ar eilute(rows) ar stulpeliu(columns)? Kad geriau suprastumét uzdékite
tai ant Rows, tai ant Columns ir stebékite pavyzdi.

b. Series - tai yra lyginamojo dalyko pavadinimas ar pan. miisy atveju tai bus
Pirmadienis, Antradienis ir t.t. Naudojantis Chart Wizard daugumai grafiky jis Series sudeda
pats ir priskiria joms teisingus parametrus name - vardas i values - reikSmeés. Miisy atveju
Name - Pirmadienis, Antradienis ir t.t., o values - 30, 28, 32 ir t.t. Tai ir iSeina, kad Serie yra
Name+Value. Siame Zingsnyje dar galima pasirinkti parametra Category (X) axis labels:
galima nurodyti X aSies kategorijas.

Pasirinkus visus parametrus antrame zingsnyje einame toliau. Next >

3. TreCiajame Zzingsnyje galésite pasirinkti uzrasus legendos, reikSmiuy vietas ir pan.

Siame zingsnyje yra SeSios kortelés, visose jiis matysite savo grafiko pakitimus pakeitus vieng ar kita
parametra.

a. Titles - ¢ia galima pasirinkti Grafiko pavadinima, parametras - Chart Title ir

asiy pavadinimus, Category (X), (Y), (Z) axis:.

b. Axes - viskas apie aSiy reikSmes. Galima pasirinkti ar rodyti reikSmes prie
atitinkamos asies.

C. Grindlines - tai linijos grafike, kurios padeda lengviau nuvesti akis prie asies
paraSytos reikSmés. Galima pasirinkti kokiais intervalais rodyti Grindlines prie atitinkamos
aSies. Major grindlines didesniais intervalais, Minor grindlines mazesniais intervalais. Galima
pasirinkti ir abu intervalus kartu.

d. Legend - legenda, jei parametras Show Legend - rodyti legenda, paisrinktas
galima dar pasirinkti legendos vieta: virSuje apacioje kairéje ir t.t.

e. Data Labels - duomeny zymuo. Galima pasirinkti ar rodyti grafike reikSmes
prie stulpelio, taSko ir pan. (priklausomai nuo grafiko tipo), ar rodyti Salia spalvos pavyzdi ir
t.t. Palieku tai i$siaiskinti patiems, nes tai néra sunku o raSymo tikrai daug.



f. Data Table - duomeny lentelé. Grafike gali buti rodoma ir lentelé, i§ korios
imami duomenys, tereikia uzdéti varnelg prie punkto Show data table. O jei prie punkto Show
legend key uzdésime varnelg, tai lenteléje matysime ir duomeny spalvos/etiketés atitikmeni.

Na grafikas jau beveik padarytas, spauskime Next > ir pereikime i paskutinj zingsni.

4. Paskutiniame zingsnyje nurodykite savo grafiko dislokacijos vieta. Ji gali biiti As new
sheet - naujame lape, tokiu atveju jraSykite pavadinima. 4s object in: - kaip objektas esamame
puslapyje, nurodykite kuriame. Spaudziate Finish.

Na ir gauname S§tai tokj grafika.

Puslapio lankomumnas

O Pirmadienis W Antradienis O Trediadienis O Fetvirtadietis
W Penktadieris O 3estadienis W Sekmadienis

Dabar dar galite pabandyti pakeisti reikSmes Ms Excel lenteléje, pamatysite, kad iSkart grafikas irgi
pasikeis. Tai pat grafika jus galite visaip formatuoti, pakeisti fono spalva, Sriftus ir pan.

AutoShapes, TextBox
Visy pirma pasiziiirékite ar pas jus yra aktyvi Drawing mygtuky juosta, jei ne, eikite View->
Toolbars-> Drawing. Atsiras §tai tokia juosta:
Drawing

Norint iterpti "AutoShapes" paspaudziame mygtuka AutoShapes, ten atsiranda saraSas grupiy: Lines,
Connectors, Basic Shapes, Block Arrows, Flochart, Stars and Banners, Callouts. Dvieju pirmyjuy grupiy
"AutoShapes" negalima paversti i "TextBox". Pasirinkus kokia nors grupg, jis matote visus tos grupés
"AutoShapes", pasirinkite, tada paspaude kairjji pelés mygtuka veskite pele, paleidg ir gausite savo norima
figtra.

Kad formatuoti savo figiira biity lengviau, Drawing juostoje pasirinkite jranki Select Object. Norint
formatuoti objekta, reikia ji pazyméti, tada Format-> AutoShape arba Ctrl+1. Atsidarys Format AutoShape
dialogo langas su keturiomis kortelémis.

1. Color and Lines - spalvos ir linijos.

a. Fill - ¢ia yra galimybé¢ pasirinkt fono spalva, o jei prie punkto Semitransparent
uzdésite varnelg, tada fono spalva bus pusiau permatoma.



b. Line - c¢ia galima pasirinkti apvadiniy linijy stori tipa, spalva. Jei jiisy
"AutoShape" 1§ grupés Connector, €ia dar taip pat galésite pakeisti jo tipa.

c. Arrows - §i grupé komandy veikia tik tada jei jisy "AutoShape" yra ne uzdara
figiira, o kreivé su laisvais galais. Cia galite ant kreivés galy uzdéti rodykles, pasirinkti ju
stiliy ir dydi. Begin Style|Size - pradzios, End Style|Size - pabaigos.

2. Size - dydis.

a. Size and rotate - Cia galite nustatyti objekto auksti Height, ploti Width
centimetrais (arba kitais matavimo vienetai priklausomai nuo to, kokie pas jus nustatyti
opcijose) ir pasukimo kampa laipsniais.

b. Scale - Cia esama objekto aukst] ir ploti galite keisti procentaliai. Jei prie
punkto Lock aspect ratio uzdésite varnelg keiCiant aukSti automatiSkai keisis plotis ir
atvirksciai, t.y. objekta iSlaikys proporcijas.

c. Kity likusiy punkty as neissiaiSkinau, bet jie man visada buvo uzdrausti.

3. Protection - lygiai taip pat, kaip lastelés protection, jei varnelé ant Locked uzdéta, tai
tada uzrakinus lapa (Sheet) objekto keisti nebus galima.

4. Properties - ¢ia galima pasirinkti:

a. Move and size with cells - jei bus pasirinktas §is punktas, tada keiciant lastelés,
kuri yra po objektu, dydi, keisis ir objekto dydis.

b. Move but don't size with cells - jei bus pasirinktas Sis punktas, tada objekto
pradzios taSkas liks biitinai tame paciame stulpelyje ir tiek pat pasitraukgs nuo kairiojo
stulpelio krasto. Keiciant stulpelio dydi, objekto dydis nesikei¢ia. Pvz.: jei miisy objektas
prasideda stulpelyje "C", tai Salia stulpelio "A" iterpus dar viena stulpeli, "C" pasislenka {
desing ir tampa "D". Tuo paciu ir objektas pasislinks i desing ir jo pradzia bus stulpelyje "D".
Eilutéms tai negalioja.

c. Don't move or size with cells - nesvarbu kaip jis bekeistuméte lasteliy dydi,
objektas visada liks toje pacioje vietoje ir tokio pat dydzio.

d. Prin object - jei Cia uzdéta varnelé, tada Sis objektas bus spausdinamas, jei ne
tai - nespausdinamas.

IS visy "AutoShapes" galima padaryti "TextBox". Pazymime objekta, paspaudziame deSinijji pelés
mygtuka ir pasirenkame Add Text. Tada jau turime "TextBox". Pazyméjus objekta veél nueikime Format->
Format AutoShape. Pamatysite, kad dialogo langas pakito, atsirado trys papildomos kortelés ir korteléje
Protection punktas Lock text (atskirai galima pasirinkti, ar uzrakinti tik objekta ar tik objekte esanti teksta).

5. Font - Sioje korteléje galite pasirinkti ijvedamo teksto formata.
6. Alignment - galite pasirinkti, kaip bus lygiuojamas jvedamas tekstas. Jei punkte

Automatic size uzdésite varnelg, tada objekto dydis bus priklausomas nuo ivesto teksto, jei vesite
teksto papildomai, tada objektas pats automatiskai didés.

7. Margins - galite nustatyti parasciy dydi nuo virSaus, apacios, kairés ir deSinés. Jei prie
punkto Automatic uzdésite varnelg, tada parastés bus minimalios.



Objekty AutoShapes, TextBox 3D formatavimas ir WordArt galimybés.

Visy pirma pradékime nuo paprasto staiakampio 3D formatavimo. (TextBox formatavimas bus
lygiai toks pat). Drawing irankiu juostoje pasirinkite jranki Rectangle ir vesdami paspaude¢ kairjji pelés
mygtuka nupieskite norimo dydzio staciakampi. Tada, vél Drawing irankiy juostoje paspauskite mygtuka 3-
D atsadyrys meniy langas, kur galima pasirinkti vieng i§ 20 stiliy. Jai jums nei vienas nepatinka, tada tame
paciame meniy pasirinkite komanda 3-D Settings..., tada atsidarys tokia jrankiy juosta:

+ 3-D Settings

DARESELXCIE-R8 SV

Cia savo norima objekta galésite ir suformatuoti, kaip tik jums patinka. Mygtuky funkcijos: (i§ kairés
1 desing)
1. 3-D On/Off - ijjungia ar i§jungia 3D.
2. Tilt Down - Suka objekta | virSy horizontalios aSies atzvilgiu.
3. Tilt Up - Suka objekta | apacia horizontalios aSies atzvilgiu.
4. Tilt Left - Suka objekta pagal laikrodzio rodykle, vertikalios aSies atZvilgiu.
5. Tilt Right - Suka objekta pries laikrodZio rodyklg, vertikalios aSies atzvilgiu.

6. Depth - Galima pasirinkti 3D objekto ilgi. Punkta Infinity galima pasirinkti tik tada, jei
sekan¢iame (Direction) punkte yra pasirinktas parametras Perspective.

7. Direction - Galima nustatyti { kuria pus¢ kryps 3D objektas (tai yra i§ kurios pusés jis
yra matomas). Taip pat galima pasirinkti ir parametrus:

a. Perspactive - objektas sueis | perspaktyva. T.y. jei punkte Depth pasirinksite
parametra Infinity jo ilgis bus toks, kol visi kampai sueis { vieng taska.

b. Parallel - objekto 3D kampai bus fiksuoti. T.y. jei jus pasirinksite stac¢iakampi,
nesvarbu koki jus ilgj darytumeéte, jis niekada nesusiaurés.

8. Lighting - Cia galima pasirinkti i§ kurios pusés i objekta krinta $viesa ir §viesos
stipruma. Bright, Normal, Dim (Ryski, Normali, Tamsi).

0. Surface - Galima pasirinkti medziaga i§ ko padarytas objektas: Wire Frame, Matte,
Plastic, Metal

10.  3-D Color - Galima pakeisti objekto 3D dalies spalva.

WordArt, tai daugiau MS Word reikalinga funkcija, bet tuo paciu jrankiu galima naudotis ir MS Excel
programoje. Drawing rankiy juostoje paspauskite mygtuka Insert WordArt arba meniy Insert-> Picture->
WordArt. 1§ pateikty pavyzdziy pasirinkite jums labiausiai patinkantj ir spauskite OK. Tada atsidariusiame
dialogo lange parasSykite teksta (galite pasirinkti fonta ir jo dydi). Tada vel OK. Atsiradus tekstui turéty
automatiskai atsirasti WordArt irankiy juosta. (jei neatsiras uzveskite pelg ant bet kurios WordArt objekto
vietos, paspauskite deSinj pelés mygtuka ir jvykdykite komanda Show WordArt Toolbar. Atsiras Stai tokia
juosta:

- \Wordart
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Siy jrankiy pagalba, galésite jvairiai pakeisti savo WordArt objekta. Mygtuky funkcijos: (i§ kairés i
desing)

1. Insert WordArt - iterpia nauja WordArt objekta.
2. Edit Text - galima pakoreguoti pazyméto WordArt objekto teksta.

3. WordArt Gallery - atidaro WordArt galerija, jei jus persigalvojote ir norite pasirinkti
kitoki WordArt'o Sablona, jusu parasytam tekstui.

4. Format WordArt - atidaro Format WordArt dialogo langa. Jis toks pat kai ir
AutoShape, tod¢l apie jji atskirai neberaSysiu.

5. WordArt Shape - leidzia pasirinkti vieng (i§ 40) Shape (formy), pasirinkus norima
forma jusy uzrasas bus jvestas | ta forma.

6. Free Rotate - Galima objekta vartyti bet kokiu kampu ir bet koki kryptimi, aplink
centro taska. (x, y, koordinaciy plokstumoje).

7. WordArt Same Letter Heights - padaro visas raides vienodo aukscio.
8. WordArt Vertical Text - uzraSas pasivercia vertikaliai.
9. WordArt Alignment - WordArt teksto lygiavimas.

10. WordArt Character Spacing - galima pasirinkti atstumus tarp simboliy.

Duomeny riiSiavimas.

Daznai i lentele suvestus duomenis reikia suriiSiuoti abécélés tvarka, jei skaiciai, tai didé¢jimo arba
mazéjimo tvarka. Toks sarasas yra malonesnis akiai ir jei jis yra atspausdintas ant popieriaus lapo, tada
zymiai lengviau susirasti jus dominancia informacija. Paimkime paprasta pavyzdi, sudarykime telefony
sqrasa:

Vardas Pavardé Telefono Nr. Adresas
Jonas Jonaitis 458974 Architekty 1-14
Petras Petraitis 598745 Gumbinés 15
Augustas Milasauskas 322511 Gytariy 18
Dovydas AliSauskas 666879 Vytauto 17-5

Taip atrodys paprastai suvesti duomenys. Dabar reikia pasirinkti, pagal koki stulpeli rasiuosime
duomenis: pagal varda, pavarde, telefono Nr. ar adresa. Taip pat mums svarbu, kad nesusimaiSyty vardai,
pavardés ir t.t., t.y., kad Jonas netapty Petraiciu, o Petras - Jonaiciu ir pan. Einame Data-> Sort... Atsidarys
Sort dialogo langas. Grupéje Sort by pasirinkite, pagal kurj stulpeli norite sur@iSiuoti. Priklausomai nuo to,
kas pasirinkta grupéje My list has, bus jusy pasirinkimo meniy. Jei bus pasirinktas parametras Header row,
tada saraSe bus iSvardinta (Vardas, Pavarde¢, Telefono Nr., Adresas), jei Non header row - (Column A ....
Column D) ir tada pavadinimai taip pat bus surtiSivojami. Grupéje My list has galimos dvi parinktys:

1. Header row - yra antrastine eilute.

2. Non header row - néra antrastinés eilutés.

Toliau reikia pasirinkti ar risiuoti maz¢jancia ar didejancia tvarka. Ascending - did¢janciai arba nuo
(A 1ki Z), Descending - maz¢janciai arba nuo (Z iki A). Paspaudus mygtuka Options atsidaro Sort Options



dialogo langas. First key sort order - galima pasirinkti, kad riSiavimas biity pagal: ménesius ar savaités
dienas. Nes sakykime jei jlisy sarasas yra pirmadienis antradienis ... sekmadienis, jums nieko gero jei bus
sudedama pagal abécéle. Tada pasirinkite pagal savaités dienas ir bus pirma pirmadieniai, paskui antradieniai
ir t.t. Grupéje Orentation galite pasirinkti lentelés orientacija: 1§ deSinés | kairg arba i§ virSau | apacia. Bet
paprastai risiuojant sarasus yra naudojamas mygtukas i§ pagrindinés jrankiy juostos Sort Ascending arba Sort
Descending. Naudojantis tais mygtukais nereikia Zyméti visos lentelés, uztenka tame stulpelyje, pagal kuri
rusiuojate, padaryti aktyvia viena lastele ir tada duomenys neissiskaido, o eiluté yra interpretuojama kaip
iraSas. Taigi atrodo tiek apie riiSiavima. O SuriiSiuota telefony saraso lentelé atrodyty Sitaip:

Vardas Pavardé Telefono Nr. Adresas
Augustas Milasauskas 322511 Gytariy 18
Dovydas AliSauskas 666879 Vytauto 17-5
Jonas Jonaitis 458974 Architekty 1-14
Petras Petraitis 598745 Gumbinés 15

Duomeny filtravimas.

Jei jus turite lentelg su dideliu duomeny sarasu, kartais prireikia matyti duomenys, kurie atitinka tam
tikra kriterijy. Pvz.: lenteléje, kur yra surasyti darbuotoju atlyginimai, jums reikia pamatyti tik ta sarasa, kuriy
atlyginimai yra 430Lt. Tokiu atveju jums prireiks stulpelyje atlyginimas uzdéti filtra equal "=" 430Lt.
Filtro naudojimui MS Excel yra komanda, Data-> Filter-> AutoFilter. Pries ja paleidziant reikia zinoti, ar
jums reikés filtruoti tik pagal vieno stulpelio duomenys ar gali prireikti kriterijy ir 18 keliy stulpeliy:

a. Jei uztenka vieno stulpelio - tada pazymekite lasteliy bloka, tame stulpelyje (butinai
paimkite antrasting eilutg) ir ivykdykite komanda AutoFilter.

b. Jei filtruoti teks pagal kelis stulpelius - tada pazymékite reikiamy stulpeliy antrastines
eilutes ir jvykdykite komanda AutoFilter.

c. Jei jus nezinote pagal keliuy stulpeliy kriterijus jums teks filtruoti, tada paprasCiausiai
pazymeékite bet kokia lasteleg, lenteléje, kur yra jisy duomenys. Tokiu atveju AutoFilter indikatorius
uzsidés ant visy stulpeliy antrastiniy eiluciy.

Norint filtruoti duomenis, reikia paspausti indikatoriy norimo stulpelio virSuje. Tada atsidaro visy to
stulpelio reikSmiy sarasas (sudétas abécélés arba didéjancia tvarka). Jei jums reikia konkrecios reikSmés, ja
pasirenkate ir paspaudziate pelés mygtuka. Tada jau matysite tik tuos irasus, kurie atitinka jisy nurodyta
kriterijy. Stulpelio, pagal kuri bus atfiltruti duomenys, indikatorius pakeis spalva, jei Windows Seting'ai
default, tada pamélynuos.

Stulpelio reikSmiy sarase yra uzrasai (4/l), (Top 10...), (Custom...). Apie kiekviena i$ ju:

1. All - reikalingas tada, kada duomenys yra atfiltruoti ir jums vél reikalingas pilnas
sgrasas.

2. Top 10... - jis veikia tik tada jei to stulpelio reik§més yra skaitinés. Galima pasirinkti
irasy skaiciy (skaiCiumi - ltems, procentais - Percent) ir ar didziausius (7Top), ar maziausius (Buttom)
{rasus atrinkti.

3. Custom... - paspaudus atsidaro Custom AutoFilter dialogo langas. Yra dvi eilutés,
kurios turi po du ivedimo laukus. Tiek pirmoje, tiek antroje eilutéje kairiajame lauke reikia pasirinkti
salyga, o deSiniajame reikSmg. Abi eilutés yra susietos logine salyga And - "ir" arba (priklausomai
nuo jisy pasirinkimo) Or - "arba". Placiau apie Siy salygu naudojima skaitykite skyrelyje "Loginiy
salygu naudojimas". Kairiojo lauko salygu reikSmes zitrékite zemiau pateiktoje lenteléje.



Desiniajame lauke galima pasirinkti reik§me i$ esanciy arba jei salyga yra, pvz is less than - maziau
uz, {rasyti reikSme, uz kurig turi biiti mazesne. Jei stulpelio reik§més yra ne skaiciai o Zodziai, tada
salygu naudojimu vargu jiis ka ar pasieksite, nes juk zodis negali buti "<" arba ">", o tik "=".
Filtruojant zodzius galima naudoti simbolius: * - bet koks kiekis, bet kokiy interpretuojamy simboliy,
? - atitinka viena bet koki simboli (pvz.: paraSius d????, gausime visus zodzius susidedancius i$
penkiy raidziy ir prasidedancius raide "d", o paraSius d*, gausime visus zodzius prasidedancius raide

Hd").
equals, does not equal Lygu, nelygu®
is greater than Daugiau uz?
is greater than or equal to Daugiau arba lygu®
is lees than MaZiau uz’
is lees than or equal to MaZiau arba lygu?
begins with, does not begin with er;iadseI:gIeda nurodyta raide, prasideda ne nurodyta
ends with, does not end with Baigiasi nurodyta raide, nesibaigia nurodyta raide’
contains, does not contain f;)igyéjs% yra nurodyta raidé, zodyje néra nurodytos

! tinka ir skaitiniams, ir zodiniams duomenims.
2 . e . e .

- tinka tik jei duomenys yra skaiciai.
3 - tinka jei duomenys yra ZodZiai.

Duomeny jvedimo formos naudojimas.

Ms Excel'io lentelé gali turéti ir duomeny bazés pavidala. Jis turi netgi turi galimybé iSsaugoti faila
*.dbf ir kitais duomeny baziy formatais. Jei jiisy failas turi duomeny bazes struktiira (lentelés virSuje gali biiti
ivairiausi uzraSai ar pagrazinimai), tada duomenims suvesti yra labai patogu naudoti forma Form, ypac, jei
jus lenteléje naudojate formules ir lentelé nuolat yra papildoma naujais jrasais. Na kaip ir daugelj dalykuy, taip
ir formos naudojima geriausiai bus apraSyti pavyzdziu. Sakykime, kad mes pardavin¢jame darZoves ir
kiekviena pardavima fiksuojame MS Excel'io lentel¢je. Lentele sudaro keturi stulpeliai: Pavadinimas,
Kiekis, Kaina ir Suma. Paprastai vedant su pirmais trimis stulpeliais taip pat nebiity jokiy problemy, bet
paskutiniame stulpelyje mums reikalinga Kiekis*Kaina. Kiek darzoviy per tam tikra laikotarpi parduosime,
mes nezinome, todel kopijuoti formulg yra nenaudingg ir be to jei naudosime paprasta sandauga, kol eilutés
nebus pilanai uzpildytos mes matysime 0. Naudojant Form Sios problemos galima iSvengti. Pirmoje eilutéje
suraSykite stulpeliy pavadinimus. Antroje eilutéje gausi pirmasis jusy irasas, ji teks parasyti nesinaudojant
tvedimo forma. "A2" - jrasykite "Pomidorai", "B2" - 2, "C2" - 8,99 ir "D2" - =B2*C2, gausime 17,98. Dabar
norint pildyti lentel¢ toliau aktyvuokite bet kuria lastelg, kuri papuola i uzpildytos lentelés bloka ir
aktyvuokite komanda: Data-> Form.... Jums atsidarys Stai tokia forma:



Darfoviy pardavimai K E2
Pornidorai =

Joje ir veskite tolimesnius duomenis. Kaip pasteb¢jote, stulpeliui Suma duomeny jvesti negalima,
kadangi, jie yra gaunami kaip kity dvieju stulpeliy sandauga. Pa¢iame formos vir§uje matysite, kiek yra Siuo
metu jraSy ir kelintas yra rodomas formoje. Norédami papildyti spauskite mygtuka New, istrinti Delete,
vaikscioti per iraSus, galima su rodyklémis aukStyn Zemyn, ir jei norite eiti tik Zzemyn su ENTER. Taip pat
galima naudoti mygtukus Find Next, Find Prev. Formos antrast¢ priklauso nuo Sheeto (puslapio)
pavadinimo. Kaip jus ji pavadinsite, tokia antrast¢ ir matysite Formos virSuje. Formai uzdaryti paspauskite
mygtuka Close, formoje arba ESC klaviatiiroje. Na tai tiek apie formas. Formoje taip pat yra mygtukai
Criteria ir Restore (jis uzdraustas), bet apie juy naudojima deja as nieko nezinau.

Macro komandos.

MS Excel'is - turi tikrai puikia funkcija, tai yra Macro komandy jrasin¢jima. Macro komanda - tai tam
tikram objektui priskirtas poprogramis Visual Basic kalba. Kaip pasidaryti macro komanda ir kokia mums i$
to nauda. Nauda yra tame, kad jei mums daznai tenka kartoti kokius nors veiksmus, mes galime padaryti taip,
kad vienu paspaudimu MS Excel'is tai atlikty pats. Na pvz.: daznai pildome lentele, kuria atsispausdiname
iStriname 1§ juos duomenis ir v¢l pildome naujais. Kad nereikéty visada trinti patiems, pasidarykime tokia
macro komanda, kuri trina jiisy lentelés duomenis. Macro komandos iraSyma suzadinsite ivykd¢ komanda
Tools-> Macro-> Record New Macro... Atsidarys Record Macro dialogo langas, ten Macro name:
pasirinkite macro komandos varda, jis gali buti bet koks zodis, tik negali biiti tarpy ir turi prasideti raide.
Shortcut key: pasirinkite klaviSu kombinacija, kuriai priskirsite macro komanda. Store macro in: - galite
pasirinkti ar $ig macro komanda naudosite tik Siame dokumente(7his Workbook), ar norite, kad ja galétumeéte
priskirti bet kokiam objektui ir kituose MS Excel dokumentuose (Personal Macro Workbook), ar ruoSite
macro komanda naujam dokumentui (New Workbook). Description: galite parasyti papildoma informacija,
ten turéty buti jraSyta data, ir autorius, kuriuo vardu yra priregistruota MS Excel programa.kai
viska suraséte spaudziate "OK". Atsiras tokia jrankiy juosta

Tada reikia atlikti visus veiksmus, kuriuos
Viska darykite neskubédami ir apgalvotai, nes tuo laiku, kal jus darysite, visus jiisy veiksmus MS
Excel'is uzrasinés tam tikrame modulyje Visual Basic programavimo kalba. Jei jiis kur nors suklysite ir
klaida atitaisysite, tai macro komanda taip ir uzsirasys ir ja vykdant taip pat bus suklysta ir klaida iStaisyta.




Geriau stengtis neklysti, nes tada poprogramio kodas bus maZzesnis ir jis bus vykdomas greic¢iau. Baigus viska
daryti paspauskite mygtuka "Stop" ant atsiradusios jrankiy juostos. Tada belieka sukurta macro komanda
priskirti kokiam nors objektui. Pvz.: Pasirinkime TextBox, su uzrasu trinti lentelg. Ant objekto paspauskite
desiniji pelés mygtuka ir atsiradusiame meniy pasirinkite komanda Assign Macro. Atsidariusiame lange
matysite savo sukurtos macro komandos pavadinima, ant jo ir bakstelkite pele, tada "OK" ir viskas, macro
komanda priskirta Siam objektui. Dabar paspaudg su pele ant TextBox ivykdysite savo sukurta macro
komanda.

Svarbu. ISsaugojus faila ir ji atidarant sekant] karta MS Excel'is prane§, kad Siame faile yra macro
komandy ir vadinasi Sis failas gali buiti uzkréstas virusu. Jei jus pats daréte §ia makro komanda arba zinote,
kad Zzmogus davgs Sig byla jiisy tikrai nenori apkreésti virusais spauskite mygtuka Enable macros, jei ne tada
Disable macros, bet antruoju atveju macro komandos faile neveiks. Jei naudojate MS Excel 2000 ir nenorite,
kad kiekviena kart atidarin¢jant faila su macro komandomis apie tai biity praneSama, tada eikite 7ools->
Macro-> Security.. ir Security Level pasirinkite Low.

Forms elementy naudojimas.
Pirmiausiai reikia isijungti irankiy juosta su Forms elementy rinkiniu. View-> Toolbars-> Forms
Atsiras $tai tokia jrankiy juosta:
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Kaip ir bet kuris objektas, taip ir forms elementas turi savo Properties dialogo langa. Visos kortelés
kartojasi, kaip ir kitose objektuose, tik Forms elementai turi dar viena kortelé - Control. Joje ir yra viskas kas
mums bus reikalinga. Objektai Label, Toggle Grid,Button ir Control Properties - Control kortelés neturi.
Tiesa Toggle Grid iSvis néra objektas. Norint iSkviesti Forms objekto Properties dialogo lango kortele
Control, reikia pazyméti objekta ir paspausti mygtuka Control Properties. MS Excel 2000 versijoje, objekto
Group Box Prperties langas su mygtuku neissikviecia, reikia paspausti desiniji pelés mygtuka ir aktyvizuoti
komanda Format Control...

A

- Label. Su Siuo jrankiu galite nustatyti plota, kuriame galite jvesti teksta.

]

- Group Box. Skirtas sugrupuoti Forms objektus i grupes. Control yra pasirinkimas 3D shading.
Galima uzdéti 3D Sesélj.
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- Button. Mygtukas, skirtas vygdyti Macro komandoms. Ji iterpus i lentelg iSkart atsiranda Assign
Macro dialogo langas.
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- Check Box. Naudojamas, kada reikia pasirinkti kelis kriterijus 1§ pateikty saraSo. Gali igyti reikSmes
TRUE/FALSE/#N/A. Control - galima pasirinkti kokia reikSmé bus pradiné: Unchecked - FALSE, Checked -
TRUE ir Mixed - #N/A. Cell link - nurodykite lastel¢ i kuria bus iSvedama reikSmé. Na Siam objektui dar taip
pat galima uzdéti ir 3D Ses¢li. Jei naudojate kelis objektus kiekvienam Cell link reikia nurodyti skirtinga
lastele.
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- Option Button. Naudojamas tada, kai i§ pateikty kriterijuy grupés galima pasirinkti tik viena. [gyja
reikSmes 1, 2, ... Sakykime jei naudojate tris Option Button, tada jei pirmas bus Checked - tai lasteléje, 1 kuria
bus nurodyta parametru Cell link gausime reikSmg 1, jei antras - 2 ir jei trecias - 3. Vienos grupés Option
Button Cell link turi butj tas pats. Pirmajam nustacius kity nusistato automatiskai. Jei viename puslapyje
norite naudoti ne viena kriterijy, pasirenkamy su Option Button, tada biitina naudoti Group Box objekta.
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- List Box. Naudojamas kai i§ saraSo reikia pasirinkti vieng kriteriju. Control - Input range, reikia
nurodyti lasteliy bloka (stulpeli arba eilutg), kuriame surasSyti kriterijai. Cell link - lastelé, kurioje bus
iSvedama reikSme priklausomai nuo pasirinkimo. /nput range esantis sarasas paeiliui igyja reikSmes 1, 2 ir t.t.
T.y. jei bus pasirinktas pirmas kriterijus, tai reikSmé bus 1, jei deSimtas - 10. Selection type Single, Multi ir
Extend.jeja a$ ¢ia aprasSiau tik Single tipa, o apie kity tipu naudojima a$ nieko paraSyti negaliu.

=

- Combo Box. Naudojimas praktiskai toks pat kaip ir List Box. Control - viskas tas pats kaip ir List
Box, i8skyrus néra Selection type ir yra Drop down lines - §iuo parametru nusistato kiek eiluciy Zemyn turi
matytis ﬁlaudoj ant scrollbar'o.

&

- Scroll Bar. Vertikalus Scroll Bar'as. Control:

1. Current value - dabarting reikSme.

2. Minimum value - minimali reikSmeé.

3. Maximum value - maximali reikSmé.

4. Incremental change - per kiek +- turi pasikeiti reikmé paspaudus apatinj arba virSutini

scrollbar'o mygtukus.

5. Page change - per kiek +- turi pasikeisti reikmé paspaudus pelés mygtuka, pelés
zymekliui esant ant tus¢ios scrollbar'o vietos.

6. Cell link - 1astelé, kurioje yra iSvedama reikSmeé.

Galimos reikSmés nuo 0 iki 30000.
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- Spinner. Naudojimas ir lygiai toks pat kaip Scroll Bar. Control visi parametrai tokie pat tik néra
Page change. Galimos reikSmés nuo 0 iki 30000.

- Control Properties. ISkviecCia pazyméto objekto Properties dialogo lango kortelg Control.

- Toggle Grid. Skirtas iSjungti ir jjungti MS Excel'io lentelés nespausdinamas linijas (Gridlines).
Lastéliy reikSmiy patvirtinimas Validation

Biina taip, kad i tam tikras lasteles reikia vesti tik teigiamus arba i$ tam tikro intervalo skaicius,
zodzius, kuriuos sudaro biitent norimas skaiCius raidziy ir pan. Tam yra skirta komanda Data-> Validation.
Ten galima nustatyti, kokias reikSmes galima jrasyti { tam tikras lasteles, ka daryti jei reikSmé neteisinga, taip
pat galima padaryti informacini langa, kuris atsiranda suaktyvinus lastel¢. Ivykdzius komanda Data->
Validation atsidarys Data Validation dialogo langas, su trimis kortelémis: Settings, Input Message ir Error
Alert

1. Settings - galima nustatyti patvirtinimo kriterijus, tik Siuos kriterijus atitinkancios
reikSmés bus galima rasyti { lastele. Jei prie Ignore balnk nuimsite varnelg, tada tuscia lastelé taip pat
neatitiks jusy kriterijy, prieSingu atveju tuscia lastelg palikti galima. A/low (sutikimo salygy) reikSmes
zilirekite zemiau pateiktoje lenteléje. Parametru Data galima pasirinkti loging salyga <> ir
pan.(Zitréti ¢ia). Priklausomai nuo antrojo ir treiojo parametry pasirinkimo atsiranda du arba vienas
ivedimo laukai. Cia reikia jvesti formule, minimalig ir (arba) maksimalia reikSmes, skai¢iy, nurodyti



lasteliy bloka ir pan. Jei lygiai toki pati lasteliy patvirtinima priskiriate lasteliy blokui ir paskui
nusprendziate ji Siek tiek pakeisti, tada padarius pakeitimus reikia prie punkto Apply these changes to
all other cells with the same settings uzdéti varnelg ir prie lasteliy esan¢iy su vienodais tvirtinimo
parametrais jie pasikeis automatiskai, net nereikia pazyméti viso lasteliy bloko.

2. Input Message - ¢ia galima padaryti praneSimo langa, kuris atsiras pazyméjus lastelg.
Prie punkto Show input message when cell is selected reikia uzdéti varnelg, tada Title dalyje jraSyti
antraStg, o Input message - zinutés teksta. Jei nenorite, kad biity rodomas paraSytas tekstas reikia
Show input message when cell is selected varnelg nuimti. Jei teksto nebuvote parase, varnelé gali ir
pasilikti, tus¢ias praneSimas néra rodomas.

3. Error Alert - Cia galite sukurti praneSimo langa, kuris atsiras jei duomenys bus ivesti
klaidingai, tai yra neatitiks setings dalyje nustatyty kriterijy. Style dalyje galima pasirinkti kokios
rusies bus praneSimas:

@- stop stiliaus langas. Jame bus Retry ir Cancel mygtukai. Paspaudus pirmaj; galésite
bandyti jvesti dar karta, o paspaudus antraji pasiliks buvusi reikSmée. Neatitinkancios kriteriju
reikSmes jvesti niekaip nepavyks.

"A- warning stiliaus langas. Jame bus Yes/No/Cancel mygtukai. Paspaudus Yes jus galésite
palikti duomenis neatitinkanc¢ius nurodytu kriterijy. No - galésite vesti duomenis i§ naujo ir
Cancel - pasiliks buvusi reikSmé.

|

‘\ll)- information stiliaus langas. Jame bus Ok/Cancel mygtukai. Sis langas skirtas tik i§vesti
informacijai apie tai, kad duomenys neatitinka jtsy nurodyto kriterijaus, bet paspaudus bet
kuri mygtuka duomenys pasilieka tie kuriuos jus jvedéte, tik skirtumas tas, kad paspaudus
Cancel pasilieka aktyvi ta pati lastelé, o Ok pereinama viena lastele Zemiau.

Languose Title ir Error message veskite atitinkamai antraste ir praneSimo teksta.

Allow (tvirtinimo, sutikimo) reikSmiy paaiskinimai.

Any value Kriterijus atitiks bet kuri reikSmé.

Whole number ] tokiq lastele bus galima rasyti tik skaitines reikSmes, kurios
atitiks Data parametrus. Tekstinés reikmés | Sig lastele rasyti
nebus galima.

List Bus galima jrasyti tik tokia reikSme, kurios bus surasytos jisy

sgrase. sgrasas gali bdti nurodytas kaip lasteliy blokas. Jei
prie punkto In-cell dropdown uzdésite varnele, tada net
nereiks rasyti reikSmiy ranka, o pazymeéjus lastele atsidarys
dropdown meniy ir galésite pasirinkti reikSme iS sgraso.

Date/Time Galima nurodyti datos/laiko intervalg, datg/laikg supranta
raSant bet kokiu formatu. ] tokig lastele galima rasyti skaicius,
bet teksto rasyti taip pat neiseis.

Text length

Galima nustatyti keliy simboliy turi biti reikSmé.

Custom

Galima jrasyti formule, kurig turi tenkinti reikSmé.
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